summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:42:41 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:57 +0200
commitd5db87ab28e8874a4dfd11dba9cb26aba0cce1cb (patch)
treef34670d8f92029ccc0dd07750dfc4603d57f8b85 /gnu
parentad362ba2bf77c645a144a8b18e006174a5cc8fc7 (diff)
gnu: Add texlive-dvidvi.
* gnu/packages/tex.scm (texlive-dvidvi): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 08bc19a3b7..1eca4acefd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1747,6 +1747,29 @@ does not contain such references. It also serves as a basis for writing DVI
drivers (much like DVItype).")
(license license:gpl3+)))
+(define-public texlive-dvidvi
+ (package
+ (name "texlive-dvidvi")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/dvidvi.1"
+ "doc/man/man1/dvidvi.man1.pdf")
+ (base32
+ "1w153rqm7nlmcf6162glxz282nbb6b6hjf5h0p7mbzr0j1357sxj")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/dvidvi")
+ (synopsis "Convert one DVI file into another")
+ (description
+ "This @command{dvidvi} converts one DVI file into another. The output
+DVI file's contents are specified by page selection commands; series of pages
+and page number ranges may be specified, as well as inclusions and
+exclusions.")
+ ;; Its author stated the program is to be used under the GPL. See
+ ;; <https://metadata.ftp-master.debian.org/changelogs//main/d/dvidvi/dvidvi_1.0-8.2_copyright>.
+ (license license:gpl3)))
+
(define-public texlive-dvipsconfig
(package
(name "texlive-dvipsconfig")