summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-03-08 15:10:53 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-16 23:39:14 +0000
commitd7e6c3cae0762d6a299162f2d7d8c44ca1390dd7 (patch)
tree176461c0df98025bd548dfc5be1c4221b6bdf284 /gnu
parent4a4f03ad5f43890903c149c4fb74d6dcbd7f8a35 (diff)
gnu: Add go-github-com-klauspost-pgzip.
* gnu/packages/golang-compression.scm (go-github-com-klauspost-pgzip): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-compression.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-compression.scm b/gnu/packages/golang-compression.scm
index b999c063ee..504491e8e0 100644
--- a/gnu/packages/golang-compression.scm
+++ b/gnu/packages/golang-compression.scm
@@ -140,6 +140,33 @@ library included in the stdlib, and supports GIF, TIFF and PDF.")
(description "@code{compress} provides various compression algorithms.")
(license license:bsd-3)))
+(define-public go-github-com-klauspost-pgzip
+ (package
+ (name "go-github-com-klauspost-pgzip")
+ (version "1.2.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/klauspost/pgzip")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1j29wr6nd9ncdbkjphyziv0h8p5s2mj222cgcfqxmzjnfn7623d8"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/klauspost/pgzip"))
+ (propagated-inputs (list go-github-com-klauspost-compress))
+ (home-page "https://github.com/klauspost/pgzip")
+ (synopsis "Parallel (de)compression of gzip files in Go")
+ (description
+ "This package implements parallel gzip compression and decompression in
+Golang and is fully compatible with @code{compress/gzip} from the standard
+library. This is beneficial for large amounts of data, say more than 1MB at a
+time, as otherwise the internal gzip library will likely be faster.")
+ (license (list license:bsd-3 license:expat))))
+
(define-public go-github-com-nwaples-rardecode-v2
(package
(name "go-github-com-nwaples-rardecode-v2")