summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2023-02-11 12:00:37 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-07 15:52:53 -0400
commitd7e8f52f773192820d3d26f622656cef70524c6b (patch)
tree4737ba4d1d74436c91d16ddeb4c31f9ee70aeb92 /gnu
parent5481aaacb5f60ba43d8db7e51cb7cc967d5eb55e (diff)
gnu: Add libpanel.
* gnu/packages/gtk.scm (libpanel): New variable. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index b9ef660a80..e4026c601f 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -3040,3 +3040,38 @@ Unix desktop environment under X11 as well as Wayland.")
(synopsis "WebP GdkPixbuf loader library")
(description "Webp-pixbuf-loader is a WebP format loader of GdkPixbuf.")
(license license:lgpl2.0+)))
+
+(define-public libpanel
+ (package
+ (name "libpanel")
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.gnome.org/GNOME/libpanel")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10lkysbwg9w0lm1hj7lw4g7y9j8b88kmq07nfgx0r6f319znj12v"))))
+ (build-system meson-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-Ddocs=disabled") ;fontconfig issue
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-gtk-update-icon-cache
+ (lambda _
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false")))))))
+ (native-inputs (list `(,glib-next "bin")
+ gobject-introspection
+ pkg-config
+ vala))
+ (inputs (list glib-next gtk libadwaita))
+ (home-page "https://gitlab.gnome.org/GNOME/libpanel")
+ (synopsis "Dock and panel library for GTK 4")
+ (description "Libpanel provides a library to create IDE-like applications
+using GTK and @code{libadwaita}. It has widgets for panels, docks, columns
+and grids of pages. Primarily, its design and implementation focus around the
+GNOME Builder and Drafting projects.")
+ (license license:lgpl3)))