summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-31 09:01:38 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-31 09:01:38 -0400
commitd80c5b936d16daf4afe020b5a8cee3214da924f3 (patch)
tree90b06df0b6cf3290768d19a5291ab2f480366ce4 /gnu
parent9eafe47e39e8f1a30fd4cd96beba024f4c67bdf5 (diff)
gnu: python-geventhttpclient: Update to 2.0.9.
* gnu/packages/python-web.scm (python-geventhttpclient): Update to 2.0.9. [propagated-inputs]: Add python-urllib3. [home-page]: Update URL.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 072d160c26..d186653544 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -26,7 +26,7 @@
;;; Copyright © 2018 Tomáš Čech <sleep_walker@gnu.org>
;;; Copyright © 2018, 2019, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
-;;; Copyright © 2018, 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2018, 2020, 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright © 2019 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
@@ -3684,13 +3684,13 @@ for the basic TCP/IP protocols.")
(define-public python-geventhttpclient
(package
(name "python-geventhttpclient")
- (version "1.5.3")
+ (version "2.0.9")
(source (origin
(method url-fetch)
(uri (pypi-uri "geventhttpclient" version))
(sha256
(base32
- "104p14p67xa5gch8dy2zqmzmjra31fflk1c1alrry8dp8bzwj3nq"))
+ "04qmcc7qpnif70ph61339dcld4g107fkhpa0gdmbs8z98v9kkg4a"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -3713,15 +3713,14 @@ for the basic TCP/IP protocols.")
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (invoke "pytest" "src/geventhttpclient/tests" "-v"
+ (invoke "pytest" "src/geventhttpclient/tests" "-v"
;; Append the test modules to sys.path to avoid
;; namespace conflict which breaks SSL tests.
"--import-mode=append")))))))
- (native-inputs
- (list python-dpkt python-pytest))
- (propagated-inputs
- (list python-brotli python-certifi python-gevent python-six))
- (home-page "https://github.com/gwik/geventhttpclient")
+ (native-inputs (list python-dpkt python-pytest))
+ (propagated-inputs (list python-brotli python-certifi python-gevent
+ python-six python-urllib3))
+ (home-page "https://github.com/geventhttpclient/geventhttpclient")
(synopsis "HTTP client library for gevent")
(description "@code{python-geventhttpclient} is a high performance,
concurrent HTTP client library for python using @code{gevent}.")