summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-12-03 09:11:58 +0100
committerFederico Beffa <beffa@fbengineering.ch>2015-12-03 09:22:30 +0100
commitd9bc0bf8fa3f305c49b1ea630ca10abff50b2149 (patch)
tree866a50ed634a76ed372469f6139bd0c5b47c7943 /gnu
parent3cbe7d5e52714410cf8b8ca58bfd37ff5ba525b8 (diff)
gnu: python2-scikit-image: Use custom 'python2-' packages.
* gnu/packages/python.scm (python2-scikit-image): Use customized 'python2-' versions of 'matplotlib', 'numpy' and 'scipy'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 655d97db18..1cbbf20bb6 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2791,7 +2791,11 @@ mining and data analysis.")
,@(package-native-inputs scikit-image)))
(propagated-inputs
`(("python2-pytz" ,python2-pytz)
- ,@(package-propagated-inputs scikit-image))))))
+ ("python2-matplotlib" ,python2-matplotlib)
+ ("python2-numpy" ,python2-numpy)
+ ("python2-scipy" ,python2-scipy)
+ ,@(fold alist-delete (package-propagated-inputs scikit-image)
+ '("python-matplotlib" "python-numpy" "python-scipy")))))))
(define-public python-redis
(package