summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-10-04 16:57:54 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-10-04 16:57:54 +0200
commitdf897e1dae8fd5b70a1ab9de53a6b1521cf2c417 (patch)
tree915aebd669a639f4229643d4223c7ab00166e594 /gnu
parent4596fb2d4c18c3a51ff5ae793c81761104b94f5b (diff)
gnu: gnugo: Fix compiling with gcc 10.
* gnu/packages/games.scm (gnugo)[arguments]: Add '-fcommon' to CFLAGS.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e279e1eb71..38f724a726 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3817,7 +3817,10 @@ either by Infocom or created using the Inform compiler.")
(base32
"0wkahvqpzq6lzl5r49a4sd4p52frdmphnqsfdv7gdp24bykdfs6s"))))
(build-system gnu-build-system)
- (inputs `(("readline" ,readline)))
+ (inputs
+ `(("readline" ,readline)))
+ (arguments
+ `(#:configure-flags '("CFLAGS=-fcommon")))
(synopsis "Play the game of Go")
(description
"GNU Go is a program that plays the game of Go, in which players