summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-09-07 23:27:08 +0800
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-17 16:29:36 -0400
commite3ea1c1eed6ff87fb0779f19d9707a1a67a3ed02 (patch)
tree6ef8ecf38c8e2d20393e6a295ead9d86aa41826e /gnu
parent6029dc25d37576dae9ed6b5a37bd2f1aa0582629 (diff)
gnu: iputils: Use new style.
* gnu/packages/networking.scm (iputils)[arguments]: Use G-expression. [native-inputs]: Remove labels.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/networking.scm29
1 files changed, 15 insertions, 14 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 1403bab363..b349bfe096 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1575,21 +1575,22 @@ intended as a substitute for the PPPStatus and EthStatus projects.")
"1qfdvr60mlwh5kr4p27wjknz1cvrwfi6iadh9ny45661v22i0njx"))))
(build-system meson-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'disable-ping-test
- (lambda _
- ;; Disable ping test, as it requires root or raw socket capabilities.
- (substitute* "test/meson.build"
- (("if build_ping == true")
- "if false")))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-ping-test
+ (lambda _
+ ;; Disable ping test, as it requires root or raw socket capabilities.
+ (substitute* "test/meson.build"
+ (("if build_ping == true")
+ "if false")))))))
(native-inputs
- `(("gettext" ,gettext-minimal)
- ("pkg-config" ,pkg-config)
- ("docbook-xsl" ,docbook-xsl)
- ("docbook-xml" ,docbook-xml)
- ("libxml2" ,libxml2) ;for XML_CATALOG_FILES
- ("xsltproc" ,libxslt)))
+ (list gettext-minimal
+ pkg-config
+ docbook-xsl
+ docbook-xml
+ libxml2 ;for XML_CATALOG_FILES
+ libxslt))
(inputs
(list libcap libidn2 openssl))
(synopsis "Collection of network utilities")