summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 18:57:52 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 19:08:31 +0200
commite63f84ae80777ee1e3ccbfc3de7543a372382580 (patch)
tree96177548cb6c347d615187a943e57176dff10c41 /gnu
parentb8530b293e6e0470f07446a2fa6ff323f2099ef1 (diff)
gnu: Add texlive-xgreek.
* gnu/packages/tex.scm (texlive-xgreek): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 052d9b5be2..ff9a22bdc0 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13146,6 +13146,32 @@ a size-change macro. Note that @file{10point.tex} is by convention called by
one of the other files, so that there's always a way back.")
(license license:public-domain)))
+(define-public texlive-xgreek
+ (package
+ (name "texlive-xgreek")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/xgreek/" "source/latex/xgreek/"
+ "tex/latex/xgreek/")
+ (base32
+ "0hmy7s53bi9szvp13zcg6hk23s8mr2ssbnmq9cw5sb8ggz8icywa")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/xgreek")
+ (synopsis "Greek language support for XeLaTeX and LuaLaTeX")
+ (description
+ "This package has been designed so to allow people to typeset Greek
+language documents using XeLaTeX or LuaLaTeX. Practically, it provides all
+the capabilities of the @samp{greek} option of the Babel package.
+
+The package can be invoked with any of the following options:
+@samp{monotonic} (for typesetting modern monotonic Greek),
+@samp{polytonic} (for typesetting modern polytonic Greek), and
+@samp{ancient} (for typesetting ancient texts). The default option is
+@samp{monotonic}.")
+ (license license:lppl1.3c)))
+
(define-public texlive-xii
(package
(name "texlive-xii")