summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:25:42 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:49:33 +0200
commite76b90b24485029f881a2e2d3852f1d02803df58 (patch)
tree8d061c180ab901b509edc68403945017ebf072d9 /gnu
parentaf5e66818f0ea1ddcc73404e3be60141e76466c0 (diff)
gnu: Add texlive-xq.
* gnu/packages/tex.scm (texlive-xq): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7ef5b178e2..b859456c51 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -14878,6 +14878,26 @@ Cyrillic Mongolian using either XeLaTeX or LuaLaTeX. The command
to be able to create multilingual documents.")
(license license:lppl1.3c)))
+(define-public texlive-xq
+ (package
+ (name "texlive-xq")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/xq/" "fonts/source/public/xq/"
+ "fonts/tfm/public/xq/" "tex/latex/xq/")
+ (base32
+ "1g9j4vdlcnidv247bmagqd7q357h6fkg3b5cx1765n38k1bx8ikx")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (native-inputs (list texlive-metafont))
+ (home-page "https://ctan.org/pkg/xq")
+ (synopsis "Support for writing about xiangqi")
+ (description
+ "The package is for writing about xiangqi or chinese chess. You can
+write games or parts of games and show diagrams with special positions.")
+ (license license:lppl)))
+
(define-public texlive-xyling
(package
(name "texlive-xyling")