summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-03-03 17:04:56 -0500
committerLeo Famulari <leo@famulari.name>2016-03-13 18:52:30 -0400
commited07b08d937a8f1f3f982f3fc825e5319c156503 (patch)
tree95bed3e849e0b5f4d809311b5d45cbe8b1362fd0 /gnu
parentd3b29319b195e3b94c468469cb2f29c2a9c859e6 (diff)
gnu: Split python2-pyicu into python-pyicu and python2-pyicu.
* gnu/packages/python.scm (python2-pyicu): Split variable into... (python-pyicu, python2-pyicu): ...both Python variants. (python-pyicu)[arguments]: Enable tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm17
1 files changed, 10 insertions, 7 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 271e15789e..9730219e7d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1133,9 +1133,9 @@ Python 3.3+.")
(package-with-python2 python-simplejson))
-(define-public python2-pyicu
+(define-public python-pyicu
(package
- (name "python2-pyicu")
+ (name "python-pyicu")
(version "1.9.2")
(source
(origin
@@ -1148,15 +1148,18 @@ Python 3.3+.")
(build-system python-build-system)
(inputs
`(("icu4c" ,icu4c)))
- (arguments
- `(#:python ,python-2 ; Python 3 works also, but needs special care for
- ; linking with libpython3.3m
- #:tests? #f)) ; no check target
(home-page "http://pyicu.osafoundation.org/")
(synopsis "Python extension wrapping the ICU C++ API")
(description
"PyICU is a python extension wrapping the ICU C++ API.")
- (license x11)))
+ (license x11)
+ (properties `((python2-variant . ,(delay python2-pyicu))))))
+
+(define-public python2-pyicu
+ (package
+ (inherit (package-with-python2
+ (strip-python2-variant python-pyicu)))
+ (native-inputs `(("python2-setuptools" ,python2-setuptools)))))
(define-public python2-dogtail
;; Python 2 only, as it leads to "TabError: inconsistent use of tabs and