summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-01-28 00:51:49 -0500
committerLeo Famulari <leo@famulari.name>2016-03-13 18:52:30 -0400
commiteed1a61fbbae973defa81a886080dd743c12c828 (patch)
treee340245b4426697c013385f9977d7a81cfb4e5e0 /gnu
parented07b08d937a8f1f3f982f3fc825e5319c156503 (diff)
gnu: Add python-vobject.
* gnu/packages/python.scm (python-vobject, python2-vobject): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9730219e7d..af3c60bac9 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8203,3 +8203,33 @@ introspection of @code{zope.interface} instances in code.")
(inherit (package-with-python2
(strip-python2-variant python-psycopg2)))
(native-inputs `(("python2-setuptools" ,python2-setuptools)))))
+
+(define-public python-vobject
+ (package
+ (name "python-vobject")
+ (version "0.9.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "vobject" version))
+ (sha256
+ (base32
+ "1cwzjnrdr9yg2x21wbf3kf59ibnchvj33mygd69yzi178a9gs9gz"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-dateutil-2" ,python-dateutil-2)
+ ("python-pyicu" ,python-pyicu)))
+ (synopsis "Parse and generate vCard and vCalendar files")
+ (description "Vobject is intended to be a full featured Python package for
+parsing and generating vCard and vCalendar files. Currently, iCalendar files
+are supported and well tested. vCard 3.0 files are supported, and all data
+should be imported, but only a few components are understood in a sophisticated
+way.")
+ (home-page "http://eventable.github.io/vobject/")
+ (license asl2.0)
+ (properties `((python2-variant . ,(delay python2-vobject))))))
+
+(define-public python2-vobject
+ (package
+ (inherit (package-with-python2
+ (strip-python2-variant python-vobject)))
+ (native-inputs `(("python2-setuptools" ,python2-setuptools)))))