summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-10-09 21:06:41 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-10 21:11:03 -0400
commiteffcbf9a7a626480207357cf5eb99a7f871de3fd (patch)
tree8e01c9e67bbc5833adfec583f09e76a6348e0cb0 /gnu
parent1de9abda666fea2c9d31a83c959fc31b96147048 (diff)
gnu: git: Drop docbook workarounds.
* gnu/packages/version-control.scm (git)[arguments]<#:phases>: Drop docbook-xsl related substitution. [native-inputs]: Add docbook-xml-4.5. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/version-control.scm15
1 files changed, 1 insertions, 14 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 25f8c2e59e..a1fc33aaf5 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -543,20 +543,6 @@ everything from small to very large projects with speed and efficiency.")
(add-after 'build 'build-subtree
(lambda* (#:key native-inputs inputs #:allow-other-keys)
(with-directory-excursion "contrib/subtree"
- (substitute* "Makefile"
- ;; Apparently `xmlto' does not bother to looks up the
- ;; stylesheets specified in the XML, unlike the above
- ;; substitution. Instead it uses a hard-coded URL. Work
- ;; around it here, but if this is common perhaps we should
- ;; hardcode this path in xmlto itself.
- (("\\$\\(XMLTO\\) -m \\$\\(MANPAGE_XSL\\)")
- (string-append "$(XMLTO) -x "
- (search-input-directory
- (or native-inputs inputs)
- (string-append
- "xml/xsl/docbook-xsl-"
- #$(package-version docbook-xsl)))
- "/manpages/docbook.xsl -m $(MANPAGE_XSL)")))
(invoke "make")
(invoke "make" "install")
(invoke "make" "install-doc")
@@ -709,6 +695,7 @@ everything from small to very large projects with speed and efficiency.")
;; For subtree documentation.
(append asciidoc
docbook2x
+ docbook-xml-4.5
docbook-xsl
libxslt
pkg-config