summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-10-09 21:06:05 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-10 21:10:56 -0400
commitf02456d993bfadef14257f3bb658ff92c4525b97 (patch)
tree598888656d3a5dfc3ed992cee0a8b7fb94e20b09 /gnu
parent15720e4bdb60dddcb7d99219c73b40032e6ef27c (diff)
gnu: libxml2: Rewrite using G-Expressions.
* gnu/packages/xml.scm (libxml2): Use G-Expressions. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xml.scm46
1 files changed, 23 insertions, 23 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 0b31bb5928..ab78796522 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -198,29 +198,29 @@ hierarchical form with variable field lengths.")
(build-system gnu-build-system)
(outputs '("out" "static" "doc"))
(arguments
- `(#:phases (modify-phases %standard-phases
- (add-after 'install 'use-other-outputs
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((src (assoc-ref outputs "out"))
- (doc (string-append (assoc-ref outputs "doc") "/share"))
- (dst (string-append (assoc-ref outputs "static")
- "/lib")))
- (mkdir-p doc)
- (mkdir-p dst)
- (for-each (lambda (dir)
- (rename-file (string-append src "/share/" dir)
- (string-append doc "/" dir)))
- '("gtk-doc"))
- (for-each (lambda (ar)
- (rename-file ar (string-append dst "/"
- (basename ar))))
- (find-files (string-append src "/lib") "\\.a$"))
-
- ;; Remove reference to the static library from the .la
- ;; file such that Libtool does the right thing when both
- ;; the shared and static variants are available.
- (substitute* (string-append src "/lib/libxml2.la")
- (("^old_library='libxml2.a'") "old_library=''"))))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'use-other-outputs
+ (lambda _
+ (let ((doc (string-append #$output:doc "/share/"))
+ (static (string-append #$output:static "/lib/")))
+ (for-each mkdir-p (list doc static))
+
+ (rename-file (string-append #$output "/share/gtk-doc")
+ (string-append doc "/gtk-doc"))
+
+ (for-each
+ (lambda (ar)
+ (rename-file ar
+ (string-append static (basename ar))))
+ (find-files (string-append #$output "/lib") "\\.a$"))
+
+ ;; Remove reference to the static library from the .la
+ ;; file such that Libtool does the right thing when both
+ ;; the shared and static variants are available.
+ (substitute* (string-append #$output "/lib/libxml2.la")
+ (("^old_library='libxml2.a'") "old_library=''"))))))))
(home-page "http://www.xmlsoft.org/")
(synopsis "C parser for XML")
(inputs (list xz))