summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-06-15 13:51:17 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-06-15 14:58:48 +0300
commitf6047c5b716e5d8f3d8a749f389954e4e4c36c16 (patch)
treeb9124679aca74a8326f7ff30e4b12ad45401d4b0 /gnu
parent5d6026ff3884e850707b97d790269e768ae934f7 (diff)
gnu: eg25-manager: Patch reference to grep.
* gnu/packages/firmware.scm (eg25-manager)[arguments]: Add a phase to patch the path to grep.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/firmware.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 7b80024b42..c7ca81c35a 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -347,9 +347,17 @@ by the b43-open driver of Linux-libre.")
(base32
"1a591dhr43mhwh09n2vlfpw6aajl6d1vkwniikjvwfjrmp01v6yq"))))
(build-system meson-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "udev/80-modem-eg25.rules"
+ (("/bin/grep") (search-input-file inputs "/bin/grep"))))))))
(native-inputs (list curl
`(,glib "bin") pkg-config))
- (inputs (list libgpiod libgudev libusb))
+ (inputs (list grep libgpiod libgudev libusb))
(synopsis "Manager daemon for the Quectel EG25 mobile broadband modem")
(description
"This package provides a manager daemon for the Quectel EG25 mobile