summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArtyom Bologov <mail@aartaka.me>2023-08-22 15:52:30 +0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-02 11:56:43 -0400
commitf9cfaf47edc68666e338650f08a802b663f2afba (patch)
treece2f6902b11bf843c115591934e335199daaa2fb /gnu
parent5978afa7908f0ea69ab31487e6d4382be5ce9a47 (diff)
gnu: sbcl-njson: Update to 1.1.1.
* gnu/packages/lisp-xyz.scm (sbcl-json): Update to 1.1.1. [description]: Update description. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index d62122f408..4ea4de5264 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -26600,7 +26600,7 @@ instead of #'FOO.
(define-public sbcl-njson
(package
(name "sbcl-njson")
- (version "1.1.0")
+ (version "1.1.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -26609,7 +26609,7 @@ instead of #'FOO.
(file-name (git-file-name "cl-njson" version))
(sha256
(base32
- "02m9l77am2rlkg83dyp3jvb76ifw1y84xh3wpz6cx7h2wkxkjnl5"))))
+ "0zdf6mlbpc2j95qm000ljf642af18sfz45yxh6rnxrbf8m4laxxa"))))
(build-system asdf-build-system/sbcl)
(inputs (list sbcl-cl-json sbcl-jzon))
(native-inputs (list sbcl-lisp-unit2))
@@ -26622,23 +26622,25 @@ instead of #'FOO.
and process JSON data, in the minimum keystrokes/minutes possible.
NJSON is parser-independent, with existing Common Lisp JSON parsers being
-loadable as additional system. @code{jzon} and @code{cl-json} backends are
-included by default, though. Conveniences that NJSON provides are:
+loadable as additional system. @code{jzon} is included by default, though.
+Conveniences that NJSON provides are:
@itemize
@item @code{encode} and @code{decode} as single entry points for JSON reading
and writing, be it from streams/string/files, or from those.
-@item @code{jget}, @code{jrem}, @code{jtruep}, and their aliases to
-access/delete the decoded objects' properties and check their truth value
-without the need to worry about the low-level details of how these values are
-decoded.
+@item @code{jget}, @code{jcopy}, @code{jkeys}, and their aliases to
+manipulate the decoded objects' properties without the need to worry
+about the low-level details of how these values are decoded.
@item @code{jif}, @code{jwhen}, @code{jor}, @code{jand}, and other macros
mimicking Lisp ones, while using truth values of JSON-decoded data.
+@item @code{jbind} and @code{jmatch} macros to destructure and
+validate parsed JSON.
+
@item @code{njson/aliases} package to nickname to @code{j} for all the
-forms conveniently accessible as @code{j:rem}, @code{j:get},
+forms conveniently accessible as @code{j:get}, @code{j:copy},
@code{j:if} etc.
@end itemize\n")