summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-01-18 18:35:59 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-01-18 22:43:58 +0100
commitfda2d75d8d886ac32e20b7c5cebff378f2e374b9 (patch)
treedb877c6f28137b8ef3f9dc714c7742de3e145c33 /gnu
parent4f7ef3f5284054c5d56b2ce7609ebf57a51e00eb (diff)
gnu: Add r-breakpointr.
* gnu/packages/bioconductor.scm (r-breakpointr): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 84a701d038..93c6165b62 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3500,6 +3500,40 @@ of Bioconductor.")
packages.")
(license license:artistic2.0)))
+(define-public r-breakpointr
+ (package
+ (name "r-breakpointr")
+ (version "1.16.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "breakpointR" version))
+ (sha256
+ (base32
+ "0j1f43lhgkapjyxlil9fflqh9nf3andhmvirdcv45y60wvljn4gx"))))
+ (properties `((upstream-name . "breakpointR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocgenerics
+ r-breakpointrdata
+ r-cowplot
+ r-doparallel
+ r-foreach
+ r-genomeinfodb
+ r-genomicalignments
+ r-genomicranges
+ r-ggplot2
+ r-gtools
+ r-iranges
+ r-rsamtools
+ r-s4vectors))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/daewoooo/BreakPointR")
+ (synopsis "Find breakpoints in Strand-seq data")
+ (description
+ "This package implements functions for finding breakpoints, plotting and
+export of Strand-seq data.")
+ (license license:expat)))
+
(define-public r-cardelino
(package
(name "r-cardelino")