summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2024-03-05 21:52:22 +0100
committerLudovic Courtès <ludo@gnu.org>2024-03-19 17:31:40 +0100
commitb7eb1a8116b2caee7acf26fb963ae998fbdb4253 (patch)
tree3aa37384d9e4b56e528f73360dec514409f4ed94 /gnu
parentb213afbf582222cf8865c17285abece3ef8f6e15 (diff)
gnu: Add alsa-midi-latency-test.
* gnu/packages/audio.scm (alsa-midi-latency-test): New variable. Change-Id: I35d3047cb997c5787de515a38ae0a0eb8f12600d Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/audio.scm37
1 files changed, 36 insertions, 1 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 578a0bd016..d2a856d8ed 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -31,7 +31,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020, 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 Jonathan Frederickson <jonathan@terracrypt.net>
-;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2020, 2024 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2020, 2021, 2023 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2021 jgart <jgart@dismail.de>
@@ -261,6 +261,41 @@ softsynth library that can be used with other applications.")
;; Player.
license:gpl3+))))
+(define-public alsa-midi-latency-test
+ (let ((version "0.0.5")
+ (revision "0")
+ (commit "07e43f8a1e6fd6d3bd97a00f2ee5afb74cb66f95"))
+ (package
+ (name "alsa-midi-latency-test")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/koppi/alsa-midi-latency-test")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0b3xd4z7zx6mmh6q2q7wnyd0hzikny2cikwzhaab3q86b551vb9n"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ;there are no tests
+ #:phases #~(modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ (invoke "sh" "./autogen.sh"))))))
+ (native-inputs (list automake autoconf libtool))
+ (inputs (list alsa-lib))
+ (synopsis "Measure the roundtrip time of MIDI messages")
+ (description
+ "@code{alsa-midi-latency-test} measures the roundtrip time of a MIDI
+message in the alsa subsystem of the Linux kernel using a high precision timer.
+It calculates the worst case roundtrip time of all sent MIDI messages and
+displays a histogram of the roundtrip time jitter.")
+ (home-page "https://github.com/koppi/alsa-midi-latency-test")
+ (license license:gpl2+))))
+
(define-public webrtc-audio-processing
(package
(name "webrtc-audio-processing")