summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-06-08 09:59:45 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-06-08 10:37:08 +0200
commit069618522d3ee040e0b0f2d9f24ceb763ce434aa (patch)
tree1a412c4cb0d7f644b5f82dff9e0f199fd9a8f8e8 /gnu
parent28d5ec153cf509135326720360628a02b2d096db (diff)
gnu: Add python-blis.
* gnu/packages/maths.scm (python-blis): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 395db2ba3f..a1a051c52e 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -96,6 +96,7 @@
#:use-module (guix build-system meson)
#:use-module (guix build-system ocaml)
#:use-module (guix build-system perl)
+ #:use-module (guix build-system pyproject)
#:use-module (guix build-system python)
#:use-module (guix build-system ruby)
#:use-module (gnu packages algebra)
@@ -4773,6 +4774,35 @@ access to BLIS implementations via traditional BLAS routine calls.")
(define ignorance blis)
+;; It is unfortunate that we cannot just link with the existing blis package.
+(define-public python-blis
+ (package
+ (name "python-blis")
+ (version "0.9.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "blis" version))
+ (sha256
+ (base32
+ "0vrnzk9jx7fcl56q6zpa4w4mxkr4iknxs42fngn9g78zh1kc9skw"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'build 'build-ext
+ (lambda _
+ (invoke "python" "setup.py" "build_ext" "--inplace"
+ "-j" (number->string (parallel-job-count))))))))
+ (propagated-inputs (list python-numpy))
+ (native-inputs (list python-cython python-pytest))
+ (home-page "https://github.com/explosion/cython-blis")
+ (synopsis "Blis as a self-contained C-extension for Python")
+ (description
+ "This package provides the Blis BLAS-like linear algebra library, as a
+self-contained C-extension for Python.")
+ (license license:bsd-3)))
+
(define-public openlibm
(package
(name "openlibm")