summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2020-11-25 20:05:53 -0600
committerBrett Gilio <brettg@gnu.org>2020-11-25 20:05:53 -0600
commit09182ee156e9e6ebfa303239713f4afc630d13bc (patch)
treef92df8ce17cfff9b7544829d73c1f2a536f78b39 /gnu
parentc9c608bdd30b249f30ffb8500d9c74852ca22172 (diff)
gnu: Add python-versioneer.
* gnu/packages/python-xyz.scm (python-versioneer): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index abcedd964d..8be5f5aab2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23022,3 +23022,26 @@ applications with variable CPU loads).")
(define-public python2-djvulibre
(package-with-python2 python-djvulibre))
+
+(define-public python-versioneer
+ (package
+ (name "python-versioneer")
+ (version "0.19")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "versioneer" version))
+ (sha256
+ (base32
+ "1bmg8y78am371rd9b4clf11b8g1h7xvq8q58z03jvgdwpsdx7zm4"))))
+ (build-system python-build-system)
+ (home-page
+ "https://github.com/python-versioneer/python-versioneer")
+ (synopsis
+ "Version-string management for VCS-controlled trees")
+ (description
+ "@code{versioneer} is a tool for managing a recorded version number in
+distutils-based python projects. The goal is to remove the tedious and
+error-prone \"update the embedded version string\" step from your release
+process.")
+ (license license:public-domain)))