summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-10-15 23:32:07 +0200
committerJulien Lepiller <julien@lepiller.eu>2022-11-03 15:11:34 +0100
commit10c82778abb26267a3d3e6a3c34da1989bd2ea7b (patch)
treec200d277a5964f06d4a14320febf0bd70100a44e /gnu
parent82d9fcd9b7cfdde047ef2299e6f4a3f0d8798620 (diff)
gnu: java-commons-jcs: Update to 3.1.
* gnu/packages/java.scm (java-commons-jcs): Update to 3.1. (josm)[arguments]: Remove now unneeded phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/geo.scm9
-rw-r--r--gnu/packages/java.scm26
2 files changed, 11 insertions, 24 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index faec60ebcc..0ab711c501 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1756,15 +1756,6 @@ to the OSM opening hours specification.")
"<date>1970-01-01 00:00:00 +0000</date>"
"</commit></entry></info>"))))
#t))
- (add-before 'build 'fix-jcs
- (lambda _
- ;; This version of JOSM uses an unreleased version of commons-jcs,
- ;; which has renamed its classes to another namespace. Rename them
- ;; back so they can be used with our version of jcs.
- (substitute* (find-files "." ".*.java$")
- (("jcs3") "jcs")
- (("ICache.NAME_COMPONENT_DELIMITER") "\":\""))
- #t))
(add-before 'build 'fix-classpath
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CLASSPATH"
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index da39d92d9b..2f70413356 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -6369,14 +6369,14 @@ reduce that load.")
(define-public java-commons-jcs
(package
(name "java-commons-jcs")
- (version "2.2.1")
+ (version "3.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://apache/commons/jcs/source/"
- "commons-jcs-dist-" version "-src.tar.gz"))
+ "commons-jcs3-dist-" version "-src.tar.gz"))
(sha256
(base32
- "0syhq2npjbrl0azqfjm0gvash1qd5qjy4qmysxcrqjsk0nf9fa1q"))))
+ "0y1lm1xnsj99bf7y9mkvbzqfy8dr7ac8zcbkpsjgzb9vhabfsbac"))))
(build-system ant-build-system)
(arguments
`(#:jar-name "commons-jcs.jar"
@@ -6385,20 +6385,16 @@ reduce that load.")
#:tests? #f; requires hsqldb
#:phases
(modify-phases %standard-phases
- (add-before 'build 'prepare
+ (add-before 'build 'copy-resources
(lambda _
- (with-directory-excursion
- "commons-jcs-core/src/main/java/org/apache/commons/jcs"
- (substitute*
- "auxiliary/disk/jdbc/dsfactory/SharedPoolDataSourceFactory.java"
- (("commons.dbcp") "commons.dbcp2")
- ((".*\\.setMaxActive.*") ""))
- ;;; Remove dependency on velocity-tools
- (delete-file "admin/servlet/JCSAdminServlet.java"))
- #t)))))
+ (copy-recursively "commons-jcs-core/src/main/resources"
+ "build/classes"))))))
(propagated-inputs
- (list java-classpathx-servletapi java-commons-logging-minimal
- java-commons-httpclient java-commons-dbcp))
+ (list java-classpathx-servletapi
+ java-commons-dbcp
+ java-httpcomponents-httpclient
+ java-httpcomponents-httpcore
+ java-log4j-api))
(native-inputs
(list java-junit))
(home-page "https://commons.apache.org/proper/commons-jcs/")