summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-06 20:01:41 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-08 20:05:05 +0200
commit142899cd69e890d17690d4996d2e1dcb13b2d0f3 (patch)
treecc11be9b99ec9e976bcfe7de8c447b770ea783ae /gnu
parent15227aa81cf6ac136139d4644b5b7e8b3ccbe725 (diff)
gnu: belcard: Simplify by using G-expression.
* gnu/packages/linphone.scm (belcard)[arguments]: Rewrite as G-expression and remove all output lookups.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linphone.scm59
1 files changed, 28 insertions, 31 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index f713f2ff79..71ab01cae9 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -258,37 +258,34 @@ IETF.")
(build-system cmake-build-system)
(outputs '("out" "debug" "tester"))
(arguments
- `(#:configure-flags '("-DENABLE_STATIC=OFF")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-vcard-grammar-location
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (vcard-grammar
- (string-append out "/share/belr/grammars/vcard_grammar")))
- (substitute* "include/belcard/vcard_grammar.hpp"
- (("define VCARD_GRAMMAR \"vcard_grammar\"")
- (format #f "define VCARD_GRAMMAR ~s" vcard-grammar))))))
- (add-after 'install 'install-tester
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (tester (assoc-ref outputs "tester"))
- (test-name (string-append ,name "_tester")))
- (for-each mkdir-p
- (list (string-append tester "/bin")
- (string-append tester "/share")))
- (rename-file (string-append out "/bin/" test-name)
- (string-append tester "/bin/" test-name))
- (rename-file (string-append out "/share/" test-name)
- (string-append tester "/share/" test-name)))))
- (delete 'check)
- (add-after 'install-tester 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
- (when tests?
- (let* ((tester (assoc-ref outputs "tester"))
- (belcard_tester (string-append tester
- "/bin/belcard_tester")))
- (invoke belcard_tester))))))))
+ (list
+ #:configure-flags '(list "-DENABLE_STATIC=OFF")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-vcard-grammar-location
+ (lambda _
+ (let ((vcard-grammar
+ (string-append #$output
+ "/share/belr/grammars/vcard_grammar")))
+ (substitute* "include/belcard/vcard_grammar.hpp"
+ (("define VCARD_GRAMMAR \"vcard_grammar\"")
+ (format #f "define VCARD_GRAMMAR ~s" vcard-grammar))))))
+ (add-after 'install 'install-tester
+ (lambda _
+ (let ((test-name (string-append #$name "_tester")))
+ (for-each mkdir-p
+ (list (string-append #$output:tester "/bin")
+ (string-append #$output:tester "/share")))
+ (rename-file (string-append #$output "/bin/" test-name)
+ (string-append #$output:tester "/bin/" test-name))
+ (rename-file (string-append #$output "/share/" test-name)
+ (string-append #$output:tester "/share/" test-name)))))
+ (delete 'check)
+ (add-after 'install-tester 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke (string-append #$output:tester
+ "/bin/belcard_tester"))))))))
(inputs
(list bctoolbox belr))
(synopsis "Belledonne Communications VCard Library")