summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-09 17:40:53 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:13:01 +0200
commit14e6091b841371a6e6a97b3088c24f487d6560ac (patch)
tree1e375687a20a4b394028d59d1c8f1e031473ea03 /gnu
parent975ddd136dc5f02f9ff86ee01f655df5650019b3 (diff)
gnu: Add texlive-scheme-basic.
* gnu/packages/tex.scm (texlive-scheme-basic): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ee123263a9..0932f535fe 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11034,6 +11034,7 @@ The macros were designed for use within other macros.")
(propagated-inputs
(list texlive-amsfonts
texlive-bibtex
+ texlive-bin ;set GUIX TEXMF and engines
texlive-cm
texlive-colorprofiles
texlive-dvipdfmx
@@ -13043,6 +13044,23 @@ break statement, except that the loop does not terminate until the end of the
current iteration.")
(license license:lppl)))
+(define-public texlive-scheme-basic
+ (package
+ (name "texlive-scheme-basic")
+ (version (number->string %texlive-revision))
+ (source #f)
+ (build-system trivial-build-system)
+ (arguments (list #:builder #~(mkdir #$output)))
+ (propagated-inputs (list texlive-collection-basic texlive-collection-latex))
+ (home-page "https://www.tug.org/texlive/")
+ (synopsis "Basic scheme (plain and latex)")
+ (description
+ "This is the basic TeX Live scheme: it is a small set of files sufficient
+to typeset plain TeX or LaTeX documents in PostScript or PDF, using the
+Computer Modern fonts. This scheme corresponds to @code{collection-basic} and
+@code{collection-latex}.")
+ (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar