summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2023-02-15 23:00:08 +0100
committerChristopher Baines <mail@cbaines.net>2023-02-17 15:44:56 +0000
commit2af65d1b5d6ea9ca0f536f82a131c52ce90f2eb4 (patch)
tree65aab274fd1e75bb2c2626a3a267443f31eb0279 /gnu
parent0d4ff1c2ad9b1451e38ede6f647eae492125cc08 (diff)
gnu: Add ocaml-ptime.
* gnu/packages/ocaml.scm (ocaml-ptime): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 3c77cbfa9b..1f41af848a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3849,6 +3849,36 @@ since an arbitrary point, and @code{PCLOCK} which counts time since the Unix
epoch.")
(license license:isc)))
+(define-public ocaml-ptime
+ (package
+ (name "ocaml-ptime")
+ ;; TODO 1.1.0 has some issues, so for now we are stuck with 0.8.5
+ (version "0.8.5")
+ (source (origin
+ (method url-fetch)
+ (uri
+ "https://erratique.ch/software/ptime/releases/ptime-0.8.5.tbz")
+ (sha256
+ (base32
+ "1fxq57xy1ajzfdnvv5zfm7ap2nf49znw5f9gbi4kb9vds942ij27"))))
+ (build-system ocaml-build-system)
+ (arguments
+ `(#:build-flags (list "build" "--with-js_of_ocaml" "true" "--tests"
+ "true")
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))))
+ (propagated-inputs (list ocaml-result js-of-ocaml))
+ (native-inputs (list ocaml-findlib ocamlbuild ocaml-topkg opam))
+ (home-page "https://erratique.ch/software/ptime")
+ (synopsis "POSIX time for OCaml")
+ (description
+ "Ptime offers platform independent POSIX time support in pure OCaml. It
+provides a type to represent a well-defined range of POSIX timestamps with
+picosecond precision, conversion with date-time values, conversion with RFC
+3339 timestamps and pretty printing to a human-readable, locale-independent
+representation.")
+ (license license:isc)))
+
(define-public ocaml-mirage-unix
(package
(name "ocaml-mirage-unix")