summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorvicvbcun <guix@ikherbers.com>2022-08-08 17:45:43 +0200
committerAndreas Enge <andreas@enge.fr>2022-08-12 10:27:40 +0200
commit2b34eccbf3bb4fd9b7490954f8d9a6f2e1132b4c (patch)
tree8c9812c0a95d81a58ff08aa0f88f6046852e413d /gnu
parentd5a641dc2e28c0c944d5c4769d8171f79a187541 (diff)
gnu: lrcalc: Update to 2.1.
* gnu/packages/algebra.scm (lrcalc): Update to 2.1. [source]: Remove patch. * gnu/packages/patches/lrcalc-includes.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Unregister file. Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/algebra.scm12
-rw-r--r--gnu/packages/patches/lrcalc-includes.patch92
3 files changed, 2 insertions, 103 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index bbc06326b8..2d32d85d47 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1469,7 +1469,6 @@ dist_patch_DATA = \
%D%/packages/patches/llvm-roc-4.0.0-remove-isystem-usr-include.patch \
%D%/packages/patches/llvm-roc-5.0.0-linkdl.patch \
%D%/packages/patches/lm-sensors-hwmon-attrs.patch \
- %D%/packages/patches/lrcalc-includes.patch \
%D%/packages/patches/lsh-fix-x11-forwarding.patch \
%D%/packages/patches/lsof-fatal-test-failures.patch \
%D%/packages/patches/lua-CVE-2014-5461.patch \
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index b3f0823daf..8ccb44c434 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1628,7 +1628,7 @@ John Cremona to compute his elliptic curve database.")
(define-public lrcalc
(package
(name "lrcalc")
- (version "1.2")
+ (version "2.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1637,18 +1637,10 @@ John Cremona to compute his elliptic curve database.")
(file-name (git-file-name name version))
(sha256
(base32
- "1c12d04jdyxkkav4ak8d1aqrv594gzihwhpxvc6p9js0ry1fahss"))
- (patches (search-patches "lrcalc-includes.patch"))))
+ "0s3amf3z75hnrjyszdndrvk4wp5p630dcgyj341i6l57h43d1p4k"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf automake libtool))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'build 'fix-permission
- (lambda _
- (chmod "lrcalc.maple.src" #o644)
- #t)))))
(synopsis "Littlewood-Richardson calculator in algebraic combinatorics")
(description "The Littlewood-Richardson Calculator (lrcalc) is a
program designed to compute Littlewood-Richardson coefficients. It computes
diff --git a/gnu/packages/patches/lrcalc-includes.patch b/gnu/packages/patches/lrcalc-includes.patch
deleted file mode 100644
index e15286905b..0000000000
--- a/gnu/packages/patches/lrcalc-includes.patch
+++ /dev/null
@@ -1,92 +0,0 @@
-Patch taken from the Sage packaging system.
-
-From 4a5e1c8c3c11efdb1cbb4239825a6bf4bf1c52f8 Mon Sep 17 00:00:00 2001
-From: Anders Skovsted Buch <asbuch@math.rutgers.edu>
-Date: Sun, 29 Nov 2015 16:25:56 -0500
-Subject: [PATCH] Patch by Jeroen Demeyer to change include <vector.h> to
- "vector.h", plus similar cases.
-
----
- src/lrcalc.c | 2 +-
- src/maple.c | 4 ++--
- src/schublib.h | 2 +-
- src/symfcn.c | 6 +++---
- src/symfcn.h | 4 ++--
- 5 files changed, 9 insertions(+), 9 deletions(-)
-
-diff --git a/src/lrcalc.c b/src/lrcalc.c
-index aff3f75..60df49e 100644
---- a/src/lrcalc.c
-+++ b/src/lrcalc.c
-@@ -8,7 +8,7 @@
- #include <stdlib.h>
- extern char *optarg;
-
--#include <vectarg.h>
-+#include "vectarg.h"
-
- #include "symfcn.h"
- #include "maple.h"
-diff --git a/src/maple.c b/src/maple.c
-index fdc0768..a5f4d14 100644
---- a/src/maple.c
-+++ b/src/maple.c
-@@ -4,8 +4,8 @@
- */
-
- #include <stdio.h>
--#include <vector.h>
--#include <hashtab.h>
-+#include "vector.h"
-+#include "hashtab.h"
- #include "maple.h"
-
-
-diff --git a/src/schublib.h b/src/schublib.h
-index a8e8511..864850c 100644
---- a/src/schublib.h
-+++ b/src/schublib.h
-@@ -1,7 +1,7 @@
- #ifndef _SCHUBLIB_H
- #define _SCHUBLIB_H
-
--#include <hashtab.h>
-+#include "hashtab.h"
-
- hashtab *trans(vector *w, int vars, hashtab *res);
- hashtab *monk(int i, hashtab *slc, int rank);
-diff --git a/src/symfcn.c b/src/symfcn.c
-index 4ffbe4b..fd5df5d 100644
---- a/src/symfcn.c
-+++ b/src/symfcn.c
-@@ -5,9 +5,9 @@
-
- #include <stdio.h>
-
--#include <alloc.h>
--#include <vector.h>
--#include <hashtab.h>
-+#include "alloc.h"
-+#include "vector.h"
-+#include "hashtab.h"
-
- #include "symfcn.h"
-
-diff --git a/src/symfcn.h b/src/symfcn.h
-index b8543b1..29bb00d 100644
---- a/src/symfcn.h
-+++ b/src/symfcn.h
-@@ -1,8 +1,8 @@
- #ifndef _SYMFCN_H
- #define _SYMFCN_H
-
--#include <hashtab.h>
--#include <vector.h>
-+#include "hashtab.h"
-+#include "vector.h"
-
- int part_itr_sz(vector *part);
- int part_itr_sub(vector *part, vector *outer);
---
-2.1.1.1.g1fb337f
-