summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorconses <contact@conses.eu>2023-03-13 19:41:34 +0100
committerAndrew Tropin <andrew@trop.in>2023-03-22 13:08:49 +0400
commit331947a9c849ec8de85c162024c8b7a890a9db47 (patch)
treeca15f3a18b5615173fc6ca29aadd8b79581eda88 /gnu
parent9931e2f1b1031da508b829c9d698368367ed81db (diff)
gnu: Add python-clickgen.
* gnu/packages/python-xyz.scm (python-clickgen): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f0f003cc8b..9a49c9f194 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3833,6 +3833,28 @@ with sensible defaults out of the box.")
(base32 "06kbzd6sjfkqan3miwj9wqyddfxc2b6hi7p5s4dvqjb3gif2bdfj"))))
(arguments `())))
+(define-public python-clickgen
+ (package
+ (name "python-clickgen")
+ (version "2.1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "clickgen" version))
+ (sha256
+ (base32
+ "010j9zz0gd2za5l4hibicypnfw721x0gxp3rr0329bc97vw5maha"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-pillow python-toml python-numpy-next python-attrs))
+ (inputs (list libx11 libpng libxcursor))
+ (native-inputs (list python-wheel))
+ (home-page "https://github.com/ful1e5/clickgen")
+ (synopsis "The hassle-free cursor building toolbox")
+ (description
+ "Clickgen is an API for building X11 and Windows cursors from .png files.
+clickgen is using @code{anicursorgen} and @code{xcursorgen} under the hood.")
+ (license license:expat)))
+
(define-public python-cligj
(package
(name "python-cligj")