summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2023-02-15 23:00:09 +0100
committerChristopher Baines <mail@cbaines.net>2023-02-17 15:44:56 +0000
commit34958ee1b6cc4a829320c286a3c85d978b69d466 (patch)
treee0ce4ac65684fda73194f92367b7d390c8c906b1 /gnu
parent2af65d1b5d6ea9ca0f536f82a131c52ce90f2eb4 (diff)
gnu: Add ocaml-mirage-logs.
* gnu/packages/ocaml.scm (ocaml-mirage-logs): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 1f41af848a..83954cfd86 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3952,6 +3952,34 @@ non-profiling case.")
ocaml-mirage-profile-unix)
(append ocaml-mirage-profile-unix)))))
+(define-public ocaml-mirage-logs
+ (package
+ (name "ocaml-mirage-logs")
+ (version "1.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mirage/mirage-logs/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1wv2hz1dj38jzc8nabin9p8im43ghy8f3crv7rf9szyyzyrdanp2"))))
+ (build-system dune-build-system)
+ (propagated-inputs (list ocaml-logs ocaml-ptime ocaml-mirage-clock
+ ocaml-mirage-profile ocaml-lwt))
+ (native-inputs (list ocaml-alcotest))
+ (home-page "https://github.com/mirage/mirage-logs")
+ (synopsis
+ "Reporter for the Logs library that writes to stderr with timestamps")
+ (description
+ "Uses a Mirage @code{CLOCK} to write timestamped log messages. It can
+also log only important messages to the console, while writing all received
+messages to a ring buffer which is displayed if an exception occurs. If
+tracing is enabled (via mirage-profile), it also writes each log message to
+the trace buffer.")
+ (license license:isc)))
+
(define-public ocaml-ocurl
(package
(name "ocaml-ocurl")