summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-04 08:47:16 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:53 +0200
commit40d208e28d3c53fe3b5f3ed3b1df0889b31da279 (patch)
tree9fc254b7f59256fd19c794fdd2dfbfad1835b30d /gnu
parent0eb2181d4be571d2d7c33f091986b1c68d964970 (diff)
gnu: Add texlive-luatex85.
* gnu/packages/tex.scm (texlive-luatex85): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a5a2aadfd4..e1d7a8e3dd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4542,6 +4542,25 @@ stub package provides a compatibility layer to allow existing packages to
upgrade smoothly to the new support structure.")
(license license:lppl1.3+)))
+(define-public texlive-luatex85
+ (package
+ (name "texlive-luatex85")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/luatex85/"
+ "source/generic/luatex85/"
+ "tex/generic/luatex85/")
+ (base32
+ "02j42g9c5smgbrk898fpvrgqlxqcqi8xch23awvnbvg6y54cs573")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/luatex85")
+ (synopsis "pdfTeX aliases for LuaTeX")
+ (description
+ "The package provides emulation of pdfTeX primitives for LuaTeX v0.85+.")
+ (license license:lppl1.3+)))
+
;; TODO: We should be able to build this from the sources on Github with
;; texlive-l3build, but I haven't been able to get it to work.
(define-public texlive-luaotfload