summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-03-30 14:24:04 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-03-30 14:24:04 +0200
commit418811783ee1f3455d6394f17ffe5e221eca5e0f (patch)
treedbeec1356954d3ee4345e47b8992f393f9011354 /gnu
parentbd350536774b5285b74b3f80c9fb347883b5241a (diff)
gnu: Add r-rpmm.
* gnu/packages/cran.scm (r-rpmm): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4d391f8173..ff27112c6c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -7149,6 +7149,28 @@ is being phased out. A modern MySQL client based on Rcpp is available from
the RMariaDB package.")
(license license:gpl2)))
+(define-public r-rpmm
+ (package
+ (name "r-rpmm")
+ (version "1.25")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "RPMM" version))
+ (sha256
+ (base32
+ "1j48dh434wfhfzka0l21w6f73qlwfm70r9gdddhn504i2d5m4jph"))))
+ (properties `((upstream-name . "RPMM")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-cluster))
+ (home-page "https://cran.r-project.org/package=RPMM")
+ (synopsis "Recursively partitioned mixture model")
+ (description
+ "This package provides a recursively partitioned mixture model for Beta
+and Gaussian mixtures. This is a model-based clustering algorithm that
+returns a hierarchy of classes, similar to hierarchical clustering, but also
+similar to finite mixture models.")
+ (license license:gpl2+)))
+
(define-public r-rpostgresql
(package
(name "r-rpostgresql")