summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-09 08:47:54 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:57 +0200
commit4b61118ead54c7843d30b8009b15858f9a6683ae (patch)
tree5e3338be44424576802027e6ebdd6c0b0d791188 /gnu
parentd224cf077b1d7629a478b4f0f9a8a3c85bb7ca51 (diff)
gnu: Add texlive-collection-basic.
* gnu/packages/tex.scm (texlive-collection-basic): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index acc8b4b7ed..35fdb2a50e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10859,6 +10859,55 @@ Arguments may contain verbatim material or other special use of characters.
The macros were designed for use within other macros.")
(license license:lppl1.3)))
+(define-public texlive-collection-basic
+ (package
+ (name "texlive-collection-basic")
+ (version (number->string %texlive-revision))
+ (source #f)
+ (build-system trivial-build-system)
+ (arguments (list #:builder #~(mkdir #$output)))
+ (propagated-inputs
+ (list texlive-amsfonts
+ texlive-bibtex
+ texlive-cm
+ texlive-colorprofiles
+ texlive-dvipdfmx
+ texlive-dvips
+ texlive-ec
+ texlive-enctex
+ texlive-etex
+ texlive-etex-pkg
+ texlive-glyphlist
+ texlive-graphics-def
+ texlive-hyphen-complete
+ texlive-hyphenex
+ texlive-ifplatform
+ texlive-iftex
+ texlive-knuth-lib
+ texlive-knuth-local
+ texlive-kpathsea
+ texlive-lua-alt-getopt
+ texlive-luahbtex
+ texlive-luatex
+ texlive-makeindex
+ texlive-metafont
+ texlive-mflogo
+ texlive-mfware
+ texlive-modes
+ texlive-pdftex
+ texlive-plain
+ texlive-tex
+ texlive-tex-ini-files
+ texlive-unicode-data
+ texlive-xdvi))
+ (home-page "https://www.tug.org/texlive/")
+ (synopsis "Essential programs and files")
+ (description
+ "These files are regarded as basic for any TeX system, covering plain TeX
+macros, Computer Modern fonts, and configuration for common drivers; no
+LaTeX.")
+ (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+
(define-public texlive-grfext
(package
(name "texlive-grfext")