summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 08:44:15 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 13:14:43 +0100
commit5abebf71e91d16947d1ade8d4b97a76fc06e2be3 (patch)
tree4fc8d6858611a46211f5b71849bdec610c21a779 /gnu
parentc254415ad113ee99cfa487ba90cff64ce48a24ce (diff)
gnu: go-github-com-mattn-go-runewidth: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-mattn-go-runewidth): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. * gnu/packages/check.scm: Add (gnu packages golang-xyz) module. * gnu/packages/disk.scm: Likewise. * gnu/packages/messaging.scm: Likewise. * gnu/packages/time.scm: Likewise. * gnu/packages/weather.scm: Likewise. Change-Id: I80f8b4c31c0fd8fee7c190a7740513ee139646d4
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/check.scm1
-rw-r--r--gnu/packages/disk.scm1
-rw-r--r--gnu/packages/golang-xyz.scm28
-rw-r--r--gnu/packages/golang.scm25
-rw-r--r--gnu/packages/messaging.scm1
-rw-r--r--gnu/packages/time.scm1
-rw-r--r--gnu/packages/weather.scm3
7 files changed, 34 insertions, 26 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 99990a8980..fc13f544a1 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -81,6 +81,7 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages golang)
#:use-module (gnu packages golang-build)
+ #:use-module (gnu packages golang-xyz)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
#:use-module (gnu packages guile-xyz)
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index c2c1e6b65d..82b311f459 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -70,6 +70,7 @@
#:use-module (gnu packages gnupg)
#:use-module (gnu packages golang)
#:use-module (gnu packages golang-build)
+ #:use-module (gnu packages golang-xyz)
#:use-module (gnu packages graphics)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 1328083ef3..261c2c0ded 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -14,12 +14,14 @@
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
+;;; Copyright © 2021 raingloom <raingloom@riseup.net>
;;; Copyright © 2021, 2023, 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
;;; Copyright © 2023 Benjamin <benjamin@uvy.fr>
;;; Copyright © 2023 Fries <fries1234@protonmail.com>
;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2023 Katherine Cox-Buday <cox.katherine.e@gmail.com>
+;;; Copyright © 2023 Nguyễn Gia Phong <mcsinyx@disroot.org>
;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2023 Sergey Trofimov <sarg@sarg.org.ru>
;;; Copyright © 2023 Thomas Ieong <th.ieong@free.fr>
@@ -1785,6 +1787,32 @@ implementing features like:
(description "This package provides an idiomatic Go retry module.")
(license license:expat)))
+(define-public go-github-com-mattn-go-runewidth
+ (package
+ (name "go-github-com-mattn-go-runewidth")
+ (version "0.0.14")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mattn/go-runewidth")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1iaqw5pd7f4f2xz37540kp0828p2820g4vxx3hz089hwl331sx1v"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/mattn/go-runewidth"))
+ (propagated-inputs
+ (list go-github-com-rivo-uniseg))
+ (home-page "https://github.com/mattn/go-runewidth")
+ (synopsis "Rune width implementation for Go")
+ (description
+ "This package provides functions to get the fixed width of a character or
+string.")
+ (license license:expat)))
+
(define-public go-github-com-mattn-go-shellwords
(package
(name "go-github-com-mattn-go-shellwords")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0f36c6b696..a8f830e1d9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9186,31 +9186,6 @@ parser.")
@url{https://unicode.org/reports/tr29/, Unicode Standard Annex #29}.")
(license license:expat)))
-(define-public go-github-com-mattn-go-runewidth
- (package
- (name "go-github-com-mattn-go-runewidth")
- (version "0.0.14")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mattn/go-runewidth")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1iaqw5pd7f4f2xz37540kp0828p2820g4vxx3hz089hwl331sx1v"))))
- (build-system go-build-system)
- (arguments '(#:import-path "github.com/mattn/go-runewidth"))
- (propagated-inputs
- (list go-github-com-rivo-uniseg))
- (home-page "https://github.com/mattn/go-runewidth")
- (synopsis "Rune width implementation for Go")
- (description
- "This package provides functions to get the fixed width of a character or
-string.")
- (license license:expat)))
-
-
(define-public go-github-com-charmbracelet-bubbletea
(package
(name "go-github-com-charmbracelet-bubbletea")
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 03b7368ae0..24a9810c43 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -88,6 +88,7 @@
#:use-module (gnu packages gnupg)
#:use-module (gnu packages golang)
#:use-module (gnu packages golang-build)
+ #:use-module (gnu packages golang-xyz)
#:use-module (gnu packages gperf)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages gstreamer)
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 0bb493c27f..66f5d0b4f4 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -46,6 +46,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages geo)
#:use-module (gnu packages golang)
+ #:use-module (gnu packages golang-xyz)
#:use-module (gnu packages libffi)
#:use-module (gnu packages perl)
#:use-module (gnu packages python)
diff --git a/gnu/packages/weather.scm b/gnu/packages/weather.scm
index e95f6bb501..5a0802b211 100644
--- a/gnu/packages/weather.scm
+++ b/gnu/packages/weather.scm
@@ -23,7 +23,8 @@
#:use-module (guix packages)
#:use-module (gnu packages)
#:use-module (gnu packages golang)
- #:use-module (gnu packages golang-build))
+ #:use-module (gnu packages golang-build)
+ #:use-module (gnu packages golang-xyz))
(define-public wego
(package