summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2023-02-15 23:00:20 +0100
committerChristopher Baines <mail@cbaines.net>2023-02-17 15:44:57 +0000
commit5bb2dc0ca2a4e4bdad674f30cfd68c2c436f488a (patch)
treeceecb8a4836c37e8a79c7c52763b05f5937f9001 /gnu
parent3e15ad0329a9036d34dd147414f430be5d7db6ab (diff)
gnu: Add ocaml-async.
* gnu/packages/ocaml.scm (ocaml-async): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 87a62805fd..df9ad35006 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8490,6 +8490,41 @@ part of the Unix-oriented Async_rpc library, and is actively used in
JavaScript.")
(license license:expat)))
+(define-public ocaml-async
+ (package
+ (name "ocaml-async")
+ (version "0.15.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/janestreet/async")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pykmnsil754jsnr8gss91ykyjvivngx4ii0ih3nsg1x2jl9xmy2"))))
+ (build-system dune-build-system)
+ (propagated-inputs (list ocaml-async-kernel
+ ocaml-async-rpc-kernel
+ ocaml-async-unix
+ ocaml-core
+ ocaml-core-kernel
+ ocaml-core-unix
+ ocaml-ppx-jane
+ ocaml-ppx-log
+ ocaml-textutils))
+ ;; TODO one test dependency is deprecated, the other is nowhere to be found
+ (arguments
+ '(#:tests? #f))
+ ;; (native-inputs (list ocaml-netkit-sockets ocaml-qtest-deprecated))
+ (home-page "https://github.com/janestreet/async")
+ (synopsis "Asynchronous execution library")
+ (description
+ "Library for asynchronous programming, i.e., programming where some part
+of the program must wait for things that happen at times determined by some
+external entity (like a human or another program).")
+ (license license:expat)))
+
(define-public ocaml-textutils-kernel
(package
(name "ocaml-textutils-kernel")