summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-12-26 18:20:43 +0100
committerMarius Bakke <marius@gnu.org>2022-12-28 00:38:40 +0100
commit5f222e7b7a088d741027b8ab9908ecb4cc79751a (patch)
tree704ddc2e9481cee216bbca22fa3f06752136a5dc /gnu
parent363b20b68584d71556c2d8912dd07cbdacabdb25 (diff)
gnu: zeitgeist: Remove input labels.
* gnu/packages/gnome.scm (zeitgeist)[arguments]: Use SEARCH-INPUT-DIRECTORY instead of label. [native-inputs, inputs]: Remove labels.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm39
1 files changed, 19 insertions, 20 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c0bb62ff84..2078e91c23 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -766,8 +766,7 @@ of known objects without needing a central registrar.")
(with-directory-excursion "doc/libzeitgeist"
(substitute* "zeitgeist-gtkdoc-index.sgml"
(("http://www.oasis-open.org/docbook/xml/4.3/")
- (string-append (assoc-ref inputs "docbook-xml")
- "/xml/dtd/docbook/"))))))
+ (search-input-directory inputs "/xml/dtd/docbook/"))))))
(add-after 'patch-docbook-xml 'disable-failing-tests
(lambda _
(substitute* "test/direct/Makefile.am"
@@ -781,25 +780,25 @@ of known objects without needing a central registrar.")
;; To honor `autoreconf -vif` by build-system.
(delete-file "autogen.sh"))))))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("docbook-xml" ,docbook-xml-4.3)
- ("gettext" ,gettext-minimal)
- ("gobject-introspection" ,gobject-introspection)
- ("gtk-doc" ,gtk-doc/stable)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)
- ("vala" ,vala)
- ("xorg-server-for-tests" ,xorg-server-for-tests)))
+ (list autoconf
+ automake
+ docbook-xml-4.3
+ gettext-minimal
+ gobject-introspection
+ gtk-doc/stable
+ libtool
+ pkg-config
+ vala
+ xorg-server-for-tests))
(inputs
- `(("dee-icu" ,dee)
- ("gtk+" ,gtk+)
- ("json-glib" ,json-glib)
- ("sqlite" ,sqlite)
- ("telepathy-glib" ,telepathy-glib)
- ("python" ,python-wrapper)
- ("python-rdflib" ,python-rdflib)
- ("xapian-config" ,xapian)))
+ (list dee
+ gtk+
+ json-glib
+ sqlite
+ telepathy-glib
+ python-wrapper
+ python-rdflib
+ xapian))
(propagated-inputs
(list glib))
(synopsis "Desktop Activity Logging")