summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-06-18 12:09:26 +0100
committerChristopher Baines <mail@cbaines.net>2023-06-20 22:04:51 +0100
commit6eb15ac58e5f6187fa0223ca1568b19463156b5d (patch)
treebd1db9cecc815c60bbb74011ed423ae7c3d267cd /gnu
parent9ff91468eefe720d0ab0ab0eebd0b42368c548b5 (diff)
gnu: ruby-hocon: Update to 1.4.0.
* gnu/packages/ruby.scm (ruby-hocon): Update to 1.4.0. [arguments]: Update style.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9f887dbf6d..369d6f44ed 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5977,7 +5977,7 @@ and manipulate Git repositories by wrapping system calls to the git binary.")
(define-public ruby-hocon
(package
(name "ruby-hocon")
- (version "1.3.1")
+ (version "1.4.0")
(home-page "https://github.com/puppetlabs/ruby-hocon")
(source (origin
(method git-fetch)
@@ -5985,16 +5985,17 @@ and manipulate Git repositories by wrapping system calls to the git binary.")
(file-name (git-file-name name version))
(sha256
(base32
- "172hh2zr0n9nnszv0qvlgwszgkrq84yahrg053m68asy79zpmbqr"))))
+ "04wgv0pwrghawnl6qp346z59fvp9v37jymq8p0lsrzxa6nvrykmk"))))
(build-system ruby-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (if tests?
- (invoke "rspec")
- (format #t "test suite not run~%"))
- #t)))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (invoke "rspec")
+ (format #t "test suite not run~%")))))))
(native-inputs
(list bundler ruby-rspec))
(synopsis "HOCON config library")