summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-05-03 08:53:08 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-10-31 20:10:19 +0100
commit72315072d6ad234fc25a0d8d2a5b72f427b7e8bc (patch)
tree96073810c6b71c276b5405780a86d3e6ffa91c09 /gnu
parent6e0361d035d6204ed0a70ba646cfa3c54636d4a2 (diff)
gnu: Add r-forestplot.
* gnu/packages/cran.scm (r-forestplot): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3afedd3329..6218598a87 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -25631,6 +25631,33 @@ univariate time series forecasts including exponential smoothing via state
space models and automatic ARIMA modelling.")
(license license:gpl3)))
+(define-public r-forestplot
+ (package
+ (name "r-forestplot")
+ (version "2.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "forestplot" version))
+ (sha256
+ (base32
+ "0bzwi6ws0qjq1pqiadssynbkxxd4zjp974jfdplmv16fcyszqhyi"))))
+ (properties `((upstream-name . "forestplot")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-checkmate r-magrittr))
+ (native-inputs (list r-knitr))
+ (home-page "https://gforge.se/packages/")
+ (synopsis "Advanced forest plot using @code{grid} graphics")
+ (description
+ "This package provides a forest plot that allows for multiple
+confidence intervals per row, custom fonts for each text element,
+custom confidence intervals, text mixed with expressions, and more.
+The aim is to extend the use of forest plots beyond meta-analyses.
+This is a more general version of the original @code{rmeta} package's
+@code{forestplot()} function and relies heavily on the @code{grid}
+package.")
+ (license license:gpl2)))
+
(define-public r-formattable
(package
(name "r-formattable")