summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-12-05 23:48:14 +0000
committerLudovic Courtès <ludo@gnu.org>2023-01-08 16:11:46 +0100
commit7dbc7f6ca3eb97388f4db218e015dbeca6fef49a (patch)
tree40d7807020f8f6c2be4f8b7752d24b004d0188b1 /gnu
parente24b9b42bc9a78bc63e6824e74fc6850e8a90490 (diff)
gnu: python-jsonschema-next: Simplify package.
To have this package on the latest version Guix needs to have new Python build procedure with Hatch https://hatch.pypa.io/. * gnu/packages/python-xyz.scm (python-jsonschema-next): [build-system]: Use pyproject-build-system to simplify package. [native-inputs]: Remove python-pypa-build. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 5 insertions, 19 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bab4a907ac..fe82775cea 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3931,6 +3931,8 @@ compare, diff, and patch JSON and JSON-like structures in Python.")
(define-public python-jsonschema-next
(package
(inherit python-jsonschema)
+ ;; XXX: Update to the latest version requires new build system - Hatch
+ ;; https://hatch.pypa.io/
(version "4.5.1")
(source
(origin
@@ -3938,25 +3940,9 @@ compare, diff, and patch JSON and JSON-like structures in Python.")
(uri (pypi-uri "jsonschema" version))
(sha256
(base32 "1z0x22691jva7lwfcfh377jdmlz68zhiawxzl53k631l34k8hvbw"))))
- (arguments
- (substitute-keyword-arguments (package-arguments python-jsonschema)
- ((#:phases phases)
- #~(modify-phases #$phases
- ;; XXX: PEP 517 manual build/install procedures copied from
- ;; python-isort.
- (replace 'build
- (lambda _
- ;; ZIP does not support timestamps before 1980.
- (setenv "SOURCE_DATE_EPOCH" "315532800")
- (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((whl (car (find-files "dist" "\\.whl$"))))
- (invoke "pip" "--no-cache-dir" "--no-input"
- "install" "--no-deps" "--prefix" #$output whl))))))))
- (native-inputs (list python-pypa-build
- python-setuptools-scm
- python-twisted))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-setuptools-scm python-twisted))
(propagated-inputs
(list python-attrs
python-importlib-metadata