summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-09 18:30:51 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:01 +0200
commit7e92d1c84fa73fc1a8fa48dad6462eec01ca2003 (patch)
treea2de876cbe2536ded1272564b89a97a5b04a6e35 /gnu
parent14e6091b841371a6e6a97b3088c24f487d6560ac (diff)
gnu: Add texlive-scheme-minimal.
* gnu/packages/tex.scm (texlive-scheme-minimal): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0932f535fe..7e0c1261f5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13044,6 +13044,23 @@ break statement, except that the loop does not terminate until the end of the
current iteration.")
(license license:lppl)))
+(define-public texlive-scheme-minimal
+ (package
+ (name "texlive-scheme-minimal")
+ (version (number->string %texlive-revision))
+ (source #f)
+ (build-system trivial-build-system)
+ (arguments (list #:builder #~(mkdir #$output)))
+ (propagated-inputs (list texlive-collection-basic))
+ (home-page "https://www.tug.org/texlive/")
+ (synopsis "Minimal scheme (plain only)")
+ (description
+ "This is the minimal TeX Live scheme, with support for only plain
+TeX. (No LaTeX macros.) LuaTeX is included because Lua scripts are used in TeX
+Live infrastructure. This scheme corresponds exactly to
+@code{collection-basic}.")
+ (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+
(define-public texlive-scheme-basic
(package
(name "texlive-scheme-basic")