summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-29 23:20:23 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-04-29 23:22:30 +0300
commit8fe5ed47cbbb6ae6ed00afa8d8b4f04e216d5adc (patch)
treeb835e1de06ccac7e979129a5352e852226f1754e /gnu
parent8b660997223310e2e62addb00a407613d2adbf65 (diff)
gnu: rust: Disable support for aarch64-linux, riscv64-linux.
Support is currently broken and blocks too many other packages. * gnu/packages/gnome.scm (librsvg-for-system): Only use librsvg on x86_64-linux. * gnu/packages/rust.scm (rust-bootstrap)[supported-systems]: Remove aarch64-linux, riscv64-linux.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm5
-rw-r--r--gnu/packages/rust.scm4
2 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 7aa7180f5e..29d75e2894 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3671,10 +3671,9 @@ diagrams.")
(system (or (%current-target-system)
(%current-system))))
;; Since librsvg 2.50 depends on Rust, and Rust is only correctly supported
- ;; on x86_64 and aarch64 so far, use the ancient C version on other
+ ;; on x86_64, aarch64 and riscv64 so far, use the ancient C version on other
;; platforms (FIXME).
- (if (or (string-prefix? "x86_64-" system)
- (string-prefix? "aarch64-" system))
+ (if (string-prefix? "x86_64-" system)
librsvg
librsvg-2.40))
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index d07f4ef10c..9af4ae2703 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -346,7 +346,9 @@ safety and thread safety guarantees.")
;; therefore the build process needs 8GB of RAM while building.
;; It may support i686 soon:
;; <https://github.com/thepowersgang/mrustc/issues/78>.
- (supported-systems '("x86_64-linux" "aarch64-linux" "riscv64-linux"))
+ ;; XXX: The rust bootstrap is currently broken on aarch64 and riscv64,
+ ;; remove them until this is fixed.
+ (supported-systems '("x86_64-linux"))
;; Dual licensed.
(license (list license:asl2.0 license:expat))))