summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2023-03-21 01:01:00 -0500
committerGuillaume Le Vaillant <glv@posteo.net>2023-03-22 13:37:59 +0100
commit916716a7dadf6fbec45d9c82b6cc8000fa40f397 (patch)
treeb7b289b8942a2dd25980604029a5cd242c5e5fb7 /gnu
parentdff90b64b9a2a253c39b3f91082a466c91cbc5bb (diff)
gnu: cl-json: Update to 0.6.0.
* gnu/packages/lisp-xyz.scm (sbcl-cl-json): Update to 0.6.0. [source]: Update url. [home-page]: Update url. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm49
1 files changed, 23 insertions, 26 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 344435ad2a..bd981afc42 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -4478,32 +4478,29 @@ JavaScript.
(sbcl-package->ecl-package sbcl-parenscript))
(define-public sbcl-cl-json
- (let ((commit "6dfebb9540bfc3cc33582d0c03c9ec27cb913e79"))
- (package
- (name "sbcl-cl-json")
- (version (git-version "0.5" "1" commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/hankhero/cl-json")
- (commit commit)))
- (file-name (git-file-name "cl-json" version))
- (sha256
- (base32
- "0fx3m3x3s5ji950yzpazz4s0img3l6b3d6l3jrfjv0lr702496lh"))))
- (build-system asdf-build-system/sbcl)
- (native-inputs
- (list sbcl-fiveam))
- (home-page "https://github.com/hankhero/cl-json")
- (synopsis "JSON encoder and decoder for Common-Lisp")
- (description
- "@command{cl-json} provides an encoder of Lisp objects to JSON format
-and a corresponding decoder of JSON data to Lisp objects. Both the encoder
-and the decoder are highly customizable; at the same time, the default
-settings ensure a very simple mode of operation, similar to that provided by
-@command{yason} or @command{st-json}.")
- (license license:expat))))
+ (package
+ (name "sbcl-cl-json")
+ (version "0.6.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sharplispers/cl-json")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "cl-json" version))
+ (sha256
+ (base32 "12vakz47d1i7pywgb9cm2364fzykidc9m7l7b6n9lx0gn2qx9ar5"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ (list sbcl-fiveam))
+ (home-page "https://github.com/sharplispers/cl-json")
+ (synopsis "JSON encoder and decoder for Common-Lisp")
+ (description "@command{cl-json} provides an encoder of Lisp objects
+to JSON format and a corresponding decoder of JSON data to Lisp
+objects. Both the encoder and the decoder are highly customizable; at the
+same time, the default settings ensure a very simple mode of operation,
+similar to that provided by @command{yason} or @command{st-json}.")
+ (license license:expat)))
(define-public cl-json
(sbcl-package->cl-source-package sbcl-cl-json))