summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-12 11:12:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-12 14:37:04 +0100
commit94e9651241b3e827531779717952d386535801f3 (patch)
tree6fc24a63dfbb01e208715a15e1e994e80ca4dff8 /gnu
parentbc47a1bf02e9071743d56243ba5aabf4b764afc5 (diff)
gnu: Add python-pomegranate.
* gnu/packages/python-xyz.scm (python-pomegranate): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4298fd4c40..8591423116 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3320,6 +3320,46 @@ existing ones.")
a certain expected condition.")
(license license:expat)))
+(define-public python-pomegranate
+ (package
+ (name "python-pomegranate")
+ (version "0.14.8")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pomegranate" version))
+ (sha256
+ (base32
+ "0gb9srkbxzlkjyfizvxkw5y0bvnfcyiaxapz0hrdaba8j096b5i2"))
+ (modules '((guix build utils)))
+ ;; Delete generated Cython C files.
+ (snippet
+ '(for-each delete-file (find-files "." "\\.c$")))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "setup.py" "test")))))))
+ (propagated-inputs
+ (list python-joblib
+ python-networkx
+ python-numpy
+ python-pyyaml
+ python-scipy))
+ (native-inputs
+ (list python-cython
+ python-nose
+ python-pandas))
+ (home-page "https://pypi.python.org/pypi/pomegranate/")
+ (synopsis "Graphical models library for Python")
+ (description
+ "Pomegranate is a graphical models library for Python, implemented in
+Cython for speed.")
+ (license license:expat)))
+
(define-public python-poyo
(package
(name "python-poyo")