summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-09 07:35:51 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:56 +0200
commita2e8d5d62e76ac50791d1641edc0087677d13912 (patch)
tree71cdbb5a6482193e628e104ae40372e02eda5e1e /gnu
parent3556df7323637d23c1b38e6adccdac45745810aa (diff)
gnu: Add texlive-makeindex.
* gnu/packages/tex.scm (texlive-makeindex): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f89084b2e5..c545f1c381 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5501,6 +5501,30 @@ always (re)defines a command. There is also @code{\\makeenvironment} and
@code{\\provideenvironment} for environments.")
(license license:lppl1.3c+)))
+(define-public texlive-makeindex
+ (package
+ (name "texlive-makeindex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/makeindex.1"
+ "doc/man/man1/makeindex.man1.pdf"
+ "doc/man/man1/mkindex.1"
+ "doc/man/man1/mkindex.man1.pdf"
+ "doc/support/makeindex/"
+ "makeindex/base/"
+ "tex/plain/makeindex/")
+ (base32
+ "197zgsrca14paavzknjx2q4ayl0lrma0z8q78ir6536s9xwn0w33")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/makeindexk")
+ (synopsis "Makeindex development sources")
+ (description
+ "The package contains the development sources of MakeIndex.")
+ (license
+ (license:fsf-free "https://mirrors.ctan.org/indexing/makeindex/COPYING"))))
+
(define-public texlive-marginfix
(package
(name "texlive-marginfix")