summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-17 21:26:36 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-17 22:23:26 -0400
commitb1b801f5f340a3f4654c8f190b8160c4af4e9e79 (patch)
tree37704ed1731593c2a380385ea0b7ad4fe5c8bf4d /gnu
parent351bf8f6fb9aece5a345bfaf1c8a75e743fe6db8 (diff)
gnu: pcmanfm: Build with GTK 3.
* gnu/packages/lxde.scm (pcmanfm)[arguments]: New field. [inputs]: Replace gtk+2 with gtk+.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lxde.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index 955dc2ffeb..a0879dd229 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -241,11 +241,12 @@ speed up the access to freedesktop.org defined application menus.")
(base32
"1xqc2k2jh165mm81xg0ghxx0ml1s3rhh4ndvbzkcri4kfhj7pjql"))))
(build-system gnu-build-system)
- (inputs (list gtk+-2 gvfs ; for trash and mount support
+ (arguments (list #:configure-flags #~(list "--with-gtk=3")))
+ (inputs (list gtk+ gvfs ;for trash and mount support
libfm libx11))
(native-inputs (list intltool libtool pkg-config))
(propagated-inputs
- (list lxmenu-data)) ; for "Open With..." application list
+ (list lxmenu-data)) ;for "Open With..." application list
(synopsis "LXDE file manager")
(description "PCMan is a lightweight GTK+ based file manager, compliant
with freedesktop.org standard.")