summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNoé Lopez <noelopez@free.fr>2024-06-18 13:51:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-06-18 23:56:07 +0200
commitca28777a8f2f07612e2db887eb3023237d786fe5 (patch)
tree4306f9e11692a11652b8eeeb09e6535ae96fc97d /gnu
parenta575d0f5d5322bac977423b6bd2742c8dc5a14a6 (diff)
gnu: Add emacs-smudge.
* gnu/packages/emacs-xyz.scm (emacs-smudge): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Change-Id: I4e61665f3b03c5f4a2be7608b93b9a2a188eadc6
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index da4a2340fe..361c47b7ad 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -140,6 +140,7 @@
;;; Copyright © 2024 dan <i@dan.games>
;;; Copyright © 2024 Ilya Chernyshov <ichernyshovvv@gmail.com>
;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
+;;; Copyright © 2024 Noé Lopez <noelopez@free.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24512,6 +24513,31 @@ orient yourself in the code, and tell which statements are at a given level.")
"This package allows controlling Pulseaudio from Emacs.")
(license license:gpl3+))))
+(define-public emacs-smudge
+ (let ((commit "4a9c5b34e9bc0a694d0faf8c2f83dc244b8b6a2f")
+ (revision "1"))
+ (package
+ (name "emacs-smudge")
+ (version (git-version "1.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/danielfm/smudge")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xiqxw87sdk9mgy7fdbmzqaf58dc1grhkigirg1bd0b2q5kbnbwx"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-oauth2 emacs-request emacs-simple-httpd))
+ (home-page "https://github.com/danielfm/smudge")
+ (synopsis "Control the Spotify application from within Emacs")
+ (description
+ "Smudge allows you to control the Spotify application from Emacs,
+either via D-BUS or Spotify Connect if you have a Spotify premium
+subscription.")
+ (license license:gpl3+))))
+
(define-public emacs-pulsar
(package
(name "emacs-pulsar")