summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorc4droid <c4droid@foxmail.com>2023-03-28 16:04:22 +0800
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-30 18:16:30 +0200
commitcca7d02463bd9241d19f10e6b00c517ca16526bc (patch)
tree6f6409ac8dd0b65f19ac5ece073b167e57aafed2 /gnu
parent7ff5deda4db2fd5852148f1daf27502e6574e032 (diff)
gnu: Add emacs-tintin-mode.
* gnu/packages/emacs-xyz.scm (emacs-tintin-mode): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 388fb6e8c2..487a6e11a2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -36613,6 +36613,27 @@ a Vertico extension which provides a way to pop up a frame at point to show
a vertical completion UI.")
(license license:gpl3+)))
+(define-public emacs-tintin-mode
+ (let ((commit "82e71e1db92ee3d94c7d0208bafc5de337193de8")
+ (revision "1"))
+ (package
+ (name "emacs-tintin-mode")
+ (version (git-version "1.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sunwayforever/tintin-mode")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1p6ryqb8m30cp0zyawb6bs8wy3ga7gm60lcan0xx1fy3wx8qip33"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/sunwayforever/tintin-mode")
+ (synopsis "Emacs major mode for highlighting and indenting TinTin++ scripts.")
+ (description "This major mode focuses on highlighting as many aspects of the TinTin++ scripting language as possible, organizing commands into functional categories and highlighting specific modes that many commands use to accomplish different tasks.")
+ (license license:asl2.0))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar