summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-01-09 14:49:25 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-01-09 14:50:26 +0100
commitde48bcee070b8d1ea6f3abe24be28d3b7d1aff68 (patch)
treed3e76c30b1b62fde1f75439e5af02fdebf8940c6 /gnu
parent35ecbb418c03e3957ebab87af921742466fe2de9 (diff)
gnu: Add r-gg3d.
* gnu/packages/bioinformatics.scm (r-gg3d): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 08d9d83471..6e909773a7 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7689,6 +7689,38 @@ sequence.")
(supported-systems '("i686-linux" "x86_64-linux"))
(license license:bsd-3)))
+(define-public r-gg3d
+ (let ((commit "ffdd837d30c1671cd0895db94bdd7b1594dbfcb0")
+ (revision "1"))
+ (package
+ (name "r-gg3d")
+ (version (git-version "0.0.0.9000" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/AckerDWM/gg3D")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0vz5laj5vz9m1jzb7h7q9f37zjmxwhylhaidlsg61r57wpxvjr3p"))))
+ (properties `((upstream-name . "gg3D")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-dplyr
+ r-ggplot2
+ r-magrittr
+ r-plot3d
+ r-plyr
+ r-scales))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/AckerDWM/gg3D")
+ (synopsis "3D perspective plots for ggplot2")
+ (description
+ "This package adds 3D perspective plotting of points, paths, and line,
+3D perspective axes, 3D perspective annotations, and wireframe plots.")
+ (license license:gpl3+))))
+
(define-public r-gutils
(let ((commit "10e36c7b580aacb2d952140a3fdd82418aaddea6")
(revision "1"))