summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-04 00:23:33 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:49 +0200
commite8a3aaa97b015fb680cd219339102ca2f5877b8a (patch)
treea36ddec3c6214220bbe3905ea587d4f741d39695 /gnu
parent47913ab45276ff45ab47687e1b67b5bc103089df (diff)
gnu: Add texlive-tex.
* gnu/packages/tex.scm (texlive-tex): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 69bf45ed08..9afc66540f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -549,6 +549,43 @@ This package contains the binaries.")
(license (license:fsf-free "https://www.tug.org/texlive/copying.html"))
(home-page "https://www.tug.org/texlive/")))
+(define-public texlive-tex
+ (package
+ (name "texlive-tex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/initex.1"
+ "doc/man/man1/initex.man1.pdf"
+ "doc/man/man1/tex.1"
+ "doc/man/man1/tex.man1.pdf")
+ (base32
+ "0njmxc6l84j44k48qh7d79n3qznzriz2pf8lkj09i7mkkj9fw9lf")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments
+ (list #:texlive-latex-base #f
+ #:create-formats #~(list "tex")))
+ (propagated-inputs
+ (list texlive-cm
+ texlive-hyphen-base
+ texlive-knuth-lib
+ texlive-kpathsea
+ texlive-plain))
+ (home-page "https://ctan.org/pkg/tex")
+ (synopsis "Sophisticated typesetting engine")
+ (description
+ "TeX is a typesetting system that incorporates a macro processor. A TeX
+source document specifies or incorporates a number of macro definitions that
+instruct the TeX engine how to typeset the document. The TeX engine also uses
+font metrics generated by Metafont, or by any of several other mechanisms that
+incorporate fonts from other sources into an environment suitable for TeX.
+TeX has been, and continues, a basis and an inspiration for several other
+programs, including e-TeX and PDFTeX. The distribution includes the source of
+Knuth's TeX book; this source is there to read, as an example of writing TeX ;
+it should not be processed without Knuth's direct permission.")
+ (license license:knuth)))
+
(define-public texlive-bidi
(package
(name "texlive-bidi")