summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-01-07 14:11:55 +0100
committerMarius Bakke <marius@gnu.org>2023-01-07 21:04:26 +0100
commitedbacab9953144a3aa204f9f0eee1584ef321a8f (patch)
tree375b90e501ed9094821796355bf57286052e02a9 /gnu
parenta47c475678c3647be918ebc97cced1e8a2306993 (diff)
gnu: Use old setuptools in packages that relies on use_2to3 conversion.
This fixes a regression since 520cdf80581669646ff61e9f18f3b27045556e76 where the use_2to3 functionality was removed from setuptools. * gnu/packages/graph.scm (python-louvain)[native-inputs]: Change from PYTHON-SETUPTOOLS to PYTHON-SETUPTOOLS-57. * gnu/packages/python-check.scm (python-parameterizedtestcase)[native-inputs]: Likewise. * gnu/packages/python-xyz.scm (python-anyjson)[native-inputs]: Add PYTHON-SETUPTOOLS-57. * gnu/packages/bioinformatics.scm (python-pyvcf)[native-inputs]: Change from PYTHON-SETUPTOOLS-FOR-TENSORFLOW to PYTHON-SETUPTOOLS-57.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm2
-rw-r--r--gnu/packages/graph.scm2
-rw-r--r--gnu/packages/python-check.scm2
-rw-r--r--gnu/packages/python-xyz.scm2
4 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a4583b06c0..5aafaa6df6 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -16782,7 +16782,7 @@ for the analysis and visualization of raw nanopore signal.")
"/vcf/test")))))))
(native-inputs
;; Older setuptools is needed for use_2to3.
- (list python-cython python-setuptools-for-tensorflow))
+ (list python-cython python-setuptools-57))
(propagated-inputs
(list python-pysam python-rpy2))
(home-page "https://github.com/jamescasbon/PyVCF")
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 52c63c8654..a2f771799f 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -295,7 +295,7 @@ subplots, multiple-axes, polar charts, and bubble charts.")
(base32 "0sx53l555rwq0z7if8agirjgw4ddp8r9b949wwz8vlig03sjvfmp"))))
(build-system python-build-system)
(native-inputs
- (list python-setuptools)) ;for use_2to3 support
+ (list python-setuptools-57)) ;for use_2to3 support
(propagated-inputs
(list python-networkx python-numpy))
(home-page "https://github.com/taynaud/python-louvain")
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 486abf1c13..7cb467c166 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -2268,7 +2268,7 @@ Avocado machine readable outputs this one is streamlined (per test results).
(sha256
(base32 "0zhjmsd16xacg4vd7zb75kw8q9khn52wvad634v1bvz7swaivk2c"))))
(build-system python-build-system)
- (native-inputs (list python-setuptools)) ;for use_2to3
+ (native-inputs (list python-setuptools-57)) ;for use_2to3
(home-page
"https://github.com/msabramo/python_unittest_parameterized_test_case")
(synopsis "Parameterized tests for Python's unittest module")
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d0b54443af..df2c7ce52d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15847,8 +15847,8 @@ fast xml and html manipulation.")
;; whatever) so this transformation needs to be done before the tests
;; can be run. Maybe we could add a build step to transform beforehand
;; but it could be annoying/difficult.
- ;; We can enable tests for the Python 2 version, though, and do below.
#:tests? #f))
+ (native-inputs (list python-setuptools-57)) ;for use_2to3 support
(home-page "https://bitbucket.org/runeh/anyjson/")
(synopsis
"Wraps best available JSON implementation in a common interface")