summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-10-30 01:16:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-10-31 19:59:30 +0100
commitfc27bf5d7469ec019ff7866b3b728afa7c434f26 (patch)
tree6c5b00e8a6daf6f07ef8558366e8d707f63b0e32 /gnu
parentae94d879a1179d372e68a9fe7df14311be7b9789 (diff)
gnu: Add r-deconrnaseq.
* gnu/packages/bioconductor.scm (r-deconrnaseq): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 80acaee764..321a9621f1 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3296,6 +3296,33 @@ Shiraishi-model signatures), computing weights that reflect the contributions
of the signatures to the mutation load of the tumor.")
(license license:gpl2)))
+(define-public r-deconrnaseq
+ (package
+ (name "r-deconrnaseq")
+ (version "1.38.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "DeconRNASeq" version))
+ (sha256
+ (base32
+ "10smk88srxm58hli0fhkdfd6l5z02q58xc9mww39gkn71y0127k6"))))
+ (properties `((upstream-name . "DeconRNASeq")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-ggplot2
+ r-limsolve
+ r-pcamethods))
+ (home-page "https://bioconductor.org/packages/DeconRNASeq")
+ (synopsis
+ "Deconvolution of heterogeneous tissue samples for mRNA-Seq data")
+ (description
+ "DeconSeq is an R package for deconvolution of heterogeneous tissues
+based on mRNA-Seq data. It models the expression levels from heterogeneous
+cell populations in mRNA-Seq as the weighted average of expression from
+different constituting cell types and predicted cell type proportions of
+single expression profiles.")
+ (license license:gpl2)))
+
(define-public r-deconvr
(package
(name "r-deconvr")