summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-01-20 16:51:20 +0000
committerChristopher Baines <mail@cbaines.net>2023-02-01 08:37:35 +0000
commit0b57ebb595e1f7965c6e25b071b50a078009b88b (patch)
tree6d4f4e5144372f97168e9f4447ae7d5c98ce4d39 /gnu
parent22da3490233da4eeec3d810e676adb484235602f (diff)
gnu: vnstat: Use G-Expressions.
* gnu/packages/networking.scm (vnstat)[arguments]: Use G-Expressions. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/networking.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 74f009e14e..2e9d018294 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4575,15 +4575,16 @@ implementations.")
(inputs (list sqlite))
(native-inputs (list pkg-config check))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'disable-id-tests
- (lambda _
- (substitute*
- '("Makefile" "tests/vnstat_tests.c")
- (("tests/id_tests.c \\$") "\\")
- (("tests/id_tests.h h") "h")
- (("^.*id_tests.*$") "")))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'disable-id-tests
+ (lambda _
+ (substitute*
+ '("Makefile" "tests/vnstat_tests.c")
+ (("tests/id_tests.c \\$") "\\")
+ (("tests/id_tests.h h") "h")
+ (("^.*id_tests.*$") "")))))))
(home-page "https://humdi.net/vnstat/")
(synopsis "Network traffic monitoring tool")
(description "vnStat is a console-based network traffic monitor that keeps