summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorFelix Lechner <felix.lechner@lease-up.com>2023-05-15 11:19:05 -0700
committerHilton Chain <hako@ultrarare.space>2023-08-24 12:44:41 +0800
commit63b2d9a8f1c5251d72d44a36929b0cdf19533971 (patch)
tree3c6acdef0eaac9b47f61a9db102b57f4dc5fd51e /gnu
parentf5eb5b7cacd388ad60606163b2fe2a4d0f0c2506 (diff)
gnu: hdparm: Move to (gnu packages disk).
* gnu/packages/linux.scm (hdparm): Move to... * gnu/packages/disk.scm (hdparm): ... here. Signed-off-by: Hilton Chain <hako@ultrarare.space>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/disk.scm38
-rw-r--r--gnu/packages/linux.scm39
2 files changed, 39 insertions, 38 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index afa11d3852..9d2e170cc0 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -530,6 +530,44 @@ which respectively make and check MS-DOS FAT file systems.")
and a @command{fsck.vfat} compatibility symlink for use in an initrd.")
(license (package-license dosfstools))))
+(define-public hdparm
+ (package
+ (name "hdparm")
+ (version "9.65")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/hdparm/hdparm/"
+ "hdparm-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0jssagggg52ssl9kg99m88afghj7bm1854vyf4p96q6h23wjjjfi"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:make-flags
+ #~(list (string-append "binprefix=" #$output)
+ (string-append "manprefix=" #$output)
+ (string-append "CC=" #$(cc-for-target))
+ ;; Let Guix strip binaries and not break cross-compilation.
+ "STRIP=true")
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)) ; no configure script
+ #:tests? #f)) ; no test suite
+ (home-page "https://sourceforge.net/projects/hdparm/")
+ (synopsis "View and tune ATA disk drive parameters")
+ (description
+ "@command{hdparm} is a command-line utility to control ATA controllers and
+disk drives. It can increase performance and/or reliability by careful tuning
+of hardware settings like power and acoustic management, DMA modes, and caching.
+It can also display detailed device information, or be used as a simple
+performance benchmarking tool.
+
+@command{hdparm} provides a command line interface to various Linux kernel
+interfaces provided by the SATA/ATA/SAS @code{libata} subsystem, and the older
+IDE driver subsystem. Many external USB drive enclosures with SCSI-ATA Command
+Translation (@dfn{SAT}) are also supported.")
+ (license (license:non-copyleft "file://LICENSE.TXT"))))
+
(define-public sdparm
(package
(name "sdparm")
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 28fa34b121..cc6865f0c6 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -113,6 +113,7 @@
#:use-module (gnu packages databases)
#:use-module (gnu packages datastructures)
#:use-module (gnu packages dbm)
+ #:use-module (gnu packages disk)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
#:use-module (gnu packages elf)
@@ -5149,44 +5150,6 @@ existing Docker images. Singularity requires kernel support for container
isolation or root privileges.")
(license license:bsd-3)))
-(define-public hdparm
- (package
- (name "hdparm")
- (version "9.65")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/hdparm/hdparm/"
- "hdparm-" version ".tar.gz"))
- (sha256
- (base32
- "0jssagggg52ssl9kg99m88afghj7bm1854vyf4p96q6h23wjjjfi"))))
- (build-system gnu-build-system)
- (arguments
- (list #:make-flags
- #~(list (string-append "binprefix=" #$output)
- (string-append "manprefix=" #$output)
- (string-append "CC=" #$(cc-for-target))
- ;; Let Guix strip binaries and not break cross-compilation.
- "STRIP=true")
- #:phases
- #~(modify-phases %standard-phases
- (delete 'configure)) ; no configure script
- #:tests? #f)) ; no test suite
- (home-page "https://sourceforge.net/projects/hdparm/")
- (synopsis "View and tune ATA disk drive parameters")
- (description
- "@command{hdparm} is a command-line utility to control ATA controllers and
-disk drives. It can increase performance and/or reliability by careful tuning
-of hardware settings like power and acoustic management, DMA modes, and caching.
-It can also display detailed device information, or be used as a simple
-performance benchmarking tool.
-
-@command{hdparm} provides a command line interface to various Linux kernel
-interfaces provided by the SATA/ATA/SAS @code{libata} subsystem, and the older
-IDE driver subsystem. Many external USB drive enclosures with SCSI-ATA Command
-Translation (@dfn{SAT}) are also supported.")
- (license (license:non-copyleft "file://LICENSE.TXT"))))
-
(define-public libnvme
(package
(name "libnvme")