summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-07 21:20:36 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 14:22:21 +0000
commitb5bbfef22a51006945835dabb187ec400429128c (patch)
treeefd6f3bd36282abf31ce9c2b0cfc4420391d44d6 /gnu
parent13e682ea94d85b4d2dd856231f4e67d47a724141 (diff)
gnu: go-github-com-davecgh-go-spew: Move to golang-check.
* gnu/packages/golang.scm (go-github-com-davecgh-go-spew): Move from here ... * gnu/packages/golang-check.scm: ... to here. * gnu/packages/high-availability.scm: Add (gnu packages golang-check) module. Change-Id: I935006c3656b7bf18b91e529296778672338f094
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-check.scm38
-rw-r--r--gnu/packages/golang.scm38
-rw-r--r--gnu/packages/high-availability.scm1
3 files changed, 39 insertions, 38 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 2decd1f664..c5e30f7fe1 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -124,6 +124,44 @@
@end itemize\n")
(license license:expat))))
+(define-public go-github-com-davecgh-go-spew
+ (package
+ (name "go-github-com-davecgh-go-spew")
+ (version "1.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/davecgh/go-spew")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0hka6hmyvp701adzag2g26cxdj47g21x6jz4sc6jjz1mn59d474y"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:unpack-path "github.com/davecgh/go-spew"
+ #:import-path "github.com/davecgh/go-spew/spew"))
+ (home-page "https://github.com/davecgh/go-spew")
+ (synopsis "Deep pretty printer for Go data structures to aid in debugging")
+ (description "Package @command{spew} implements a deep pretty printer
+for Go data structures to aid in debugging.
+
+A quick overview of the additional features spew provides over the built-in
+printing facilities for Go data types are as follows:
+
+@itemize
+@item Pointers are dereferenced and followed.
+@item Circular data structures are detected and handled properly.
+@item Custom Stringer/error interfaces are optionally invoked, including on
+unexported types.
+@item Custom types which only implement the Stringer/error interfaces via a
+pointer receiver are optionally invoked when passing non-pointer variables.
+@item Byte arrays and slices are dumped like the hexdump -C command which
+includes offsets, byte values in hex, and ASCII output (only when using Dump
+style).
+@end itemize")
+ (license license:isc)))
+
(define-public go-github-com-frankban-quicktest
(package
(name "go-github-com-frankban-quicktest")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d529490b49..269bfdec95 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5345,44 +5345,6 @@ generation features. This code generation is used to achieve:
that's a lot faster (and only does simple bandwidth metrics).")
(license license:expat))))
-(define-public go-github-com-davecgh-go-spew
- (package
- (name "go-github-com-davecgh-go-spew")
- (version "1.1.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/davecgh/go-spew")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0hka6hmyvp701adzag2g26cxdj47g21x6jz4sc6jjz1mn59d474y"))))
- (build-system go-build-system)
- (arguments
- '(#:unpack-path "github.com/davecgh/go-spew"
- #:import-path "github.com/davecgh/go-spew/spew"))
- (home-page "https://github.com/davecgh/go-spew")
- (synopsis "Deep pretty printer for Go data structures to aid in debugging")
- (description "Package @command{spew} implements a deep pretty printer
-for Go data structures to aid in debugging.
-
-A quick overview of the additional features spew provides over the built-in printing facilities for Go data types are as follows:
-
-@itemize
-@item Pointers are dereferenced and followed.
-@item Circular data structures are detected and handled properly.
-@item Custom Stringer/error interfaces are optionally invoked, including on
-unexported types.
-@item Custom types which only implement the Stringer/error interfaces via a
-pointer receiver are optionally invoked when passing non-pointer variables.
-@item Byte arrays and slices are dumped like the hexdump -C command which
-includes offsets, byte values in hex, and ASCII output (only when using Dump
-style).
-@end itemize\n")
- (license license:isc)))
-
(define-public go-github-com-btcsuite-btclog
(let ((commit "84c8d2346e9fc8c7b947e243b9c24e6df9fd206a")
(revision "0"))
diff --git a/gnu/packages/high-availability.scm b/gnu/packages/high-availability.scm
index ad18a39738..0678edaf4e 100644
--- a/gnu/packages/high-availability.scm
+++ b/gnu/packages/high-availability.scm
@@ -36,6 +36,7 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages golang)
+ #:use-module (gnu packages golang-check)
#:use-module (gnu packages golang-compression)
#:use-module (gnu packages golang-crypto)
#:use-module (gnu packages golang-web)